Earlier  
Posted Nick Remark
#openstack-nova - 2017-08-25
16:14:10 mriedem there was also of course no test for the compute manager piece of that
16:14:14 mriedem i think i'm just going to remove it
16:14:17 superdan mriedem: I bet that was intending to catch migrationerror, which can be raised by _prep_resize
16:14:39 superdan mriedem: well, the comment definitely talks about the call though
16:15:07 superdan mriedem: like I said yesterday I thought that was a call, so that person did too
16:15:26 mriedem ok, i was going to say, from the change itself, it's raising that here https://review.openstack.org/#/c/73387/13/nova/virt/libvirt/driver.py
16:15:34 mriedem which on the source after the rpc cast
16:15:48 mriedem the rpc all you mentioned yesterday i thought was about something in conductor, but maybe i'm confused
16:16:02 mriedem anyway, i'm going to remove this handling from prep_resize as it can't happen
16:16:32 superdan hang on
16:16:34 superdan I'm confused
16:17:16 mriedem the libvirt driver raises that error from migrate_disk_and_power_off which is called from ComputeManager.resize_instance,
16:17:25 mriedem _prep_resize does an rpc cast to resize_instance on the source host
16:17:31 superdan mriedem: so you see that we can raise a MigrationError in there, right?
16:17:34 mriedem since it's a cast, the error raised from migrate_disk_and_power_off on the source can't come back
16:17:40 mriedem in _prep_resize?
16:17:43 superdan yeah
16:17:45 mriedem yes
16:17:49 superdan also,
16:18:01 mriedem MigrationError != MigrationPreCheckError
16:18:03 superdan we're doing the resize claim in a context manager and then the rpc call inside
16:18:12 superdan mriedem: I know, but precheck is a subclass of migration error
16:18:26 superdan mriedem: thought maybe it should be catching migrationerror instead
16:18:51 mriedem no i assume he added MigrationPreCheckError specifically b/c that's what was added to the driver to raise in tha same change
16:19:20 superdan I guess it doesn't matter regardless since we're not going to return the exception we let through to anything anyway
16:19:44 mriedem i'm not sure what the resize_claim has to do with anything,
16:19:48 mriedem that just aborts the claim on failure
16:19:58 mriedem like if the rpc cast blows up or something i guess
16:20:19 superdan mriedem: right, I'm saying there seems to be no reason to do that if we're not going to make a call
16:20:38 superdan let me take a step back
16:20:52 superdan all I'm saying is a lot of this path looks very confused about what is a blocking call vs. cas
16:20:54 superdan *cast
16:20:56 superdan that's all
16:21:15 mriedem agree
16:21:32 mriedem which is why i did this the other day https://review.openstack.org/#/c/496861/
16:21:40 mriedem because following this stupid back and forth shit is confusing
16:21:53 mriedem i've been meaning to do something like ^ for the live migration craziness for awhile too
16:22:09 mriedem like, "in this method, which is the 5th part of the live migration crazy, which fucking host am i actually on right now?!"
16:22:24 mriedem sorry for the salty language
16:26:04 kashyap mriedem: Salty language is welcome. [/me has a TODO item to write down live migration flow for Nova, too]
16:32:55 openstackgerrit Matt Riedemann proposed openstack/nova master: Remove useless error handling in prep_resize https://review.openstack.org/497976
16:34:25 openstackgerrit Dan Smith proposed openstack/nova master: Add uuid to migration object and migrate-on-load https://review.openstack.org/496934
16:39:19 openstackgerrit Eric Fried proposed openstack/nova-specs master: WIP: SPEC: Treat devices as generic resources https://review.openstack.org/497978
17:44:16 openstackgerrit Chris Dent proposed openstack/nova master: Prevent blank line at start of migration placeholders https://review.openstack.org/498004
17:44:28 cdent dansmith: your wish, my command ^
18:45:26 openstackgerrit Eric Fried proposed openstack/nova-specs master: WIP: SPEC: Treat devices as generic resources https://review.openstack.org/497978
20:02:26 mriedem artom: did you ever propose a change to the feature support matrix to doc the tagged attach stuff?
20:02:56 artom mriedem, I thought someone else did?
20:03:02 mriedem jichen?
20:03:16 mriedem ah yes https://review.openstack.org/#/c/481478/
20:03:20 artom https://review.openstack.org/#/c/481478/
20:03:27 artom Yeah, you're even a reviewer on it ;)
20:03:42 mriedem whatever artomous maximus
20:03:46 mriedem are you happy with it?
20:04:01 artom Lemme check the latest version quickly
20:04:30 mriedem stephenfin: can you drop the -2 from this https://review.openstack.org/#/c/482216/ ?
20:04:37 artom Err, nits on wording
20:04:50 artom But since this is a pure doc patch, I figure they're -1 worthy, no?
20:05:09 mriedem yes, i'm also going through it, i'll update after you
20:07:50 mriedem er i just -1ed
20:12:45 mriedem thanks
20:19:08 openstackgerrit Matt Riedemann proposed openstack/nova master: Add device tag support info in support matrix https://review.openstack.org/481478
20:19:10 mriedem updated ^
20:24:09 artom mriedem, couple more nits
20:24:14 mriedem my god
20:24:24 artom bikeshed all the things!
20:25:20 artom If it improves your morale, it's genuinely nice to see you push patches through their final stretch like this, when there's just nits remaining
20:25:44 mriedem if there is one thing i'm all about, it's high morale
20:26:50 artom A high state in general
20:30:28 mriedem oh i guess we don't format that page with rst anyway
20:30:35 mriedem so ``nic1`` doesn't help
20:31:51 artom Maybe the . thing was legit?
20:32:22 mriedem no it wasn't
20:32:26 mriedem it was just .nic1.
20:32:29 mriedem i'll use quotes
20:33:04 admin0 hi all .. i wanted to check if I hit a nova bug .. https://bugs.launchpad.net/nova/+bug/1713144 ..
20:33:05 openstack Launchpad bug 1713144 in OpenStack Compute (nova) "nova metadata service breaks on hostname" [Undecided,New]
20:33:30 artom If you hit it it'll probably defend itself and hit back
20:33:52 mriedem <rimshot>
20:34:54 admin0 :D
20:35:04 openstackgerrit Matt Riedemann proposed openstack/nova master: Add device tag support info in support matrix https://review.openstack.org/481478
20:35:05 openstackgerrit Matt Riedemann proposed openstack/nova master: Document tagged attach in the feature support matrix https://review.openstack.org/498086
20:35:15 admin0 i will wait for it to hit back :)
20:35:16 artom nova-network? Didn't we deprecate that?
20:35:46 mriedem admin0: which release? please provide release version information in the bug report
20:35:53 mriedem if something changed we need to be able to look for when
20:36:55 admin0 sorry .. i updated
20:41:27 mriedem looks like that code hasn't changed in a long time
20:41:27 mriedem netaddr.IPAddress(ip)
20:41:34 mriedem so it's probably something in the netaddr library
20:41:49 mriedem compare the versions where it works and where it doesn't and check the change log for netaddr between them i suppose
20:44:31 mriedem https://github.com/drkjam/netaddr/blob/netaddr-0.7.19/netaddr/ip/__init__.py#L244
20:44:44 mriedem looks like netaddr.IPAddress has always expected an ip rather than fqdn
20:45:09 admin0 i will take it back to ansible
20:47:40 mriedem ah, also, metadata_host defaults to $my_ip,
20:47:46 mriedem which is an IP address, not a hostname
20:47:59 mriedem these StrOpts should really probably be IPOpts
21:24:49 openstackgerrit Matt Riedemann proposed openstack/nova master: Change default for [notifications]/default_publisher_id to $host https://review.openstack.org/498094
21:24:50 openstackgerrit Matt Riedemann proposed openstack/nova master: Change CONF.my_ip to be IPOpt https://review.openstack.org/498095
21:41:59 mriedem what the hell is monkey_patch_modules?

Earlier   Later