Earlier  
Posted Nick Remark
#openstack-nova - 2017-08-14
20:47:38 clarkb mtreinish: systemd will tell you
20:47:41 clarkb I think
20:48:19 dims smcginnis : dansmith : i think i'll go with trying to patch that up first (rather than the CELLSv2_SETUP superconductor -> singleconductor)
20:49:10 mtreinish clarkb: that's what I wasn't sure of
20:54:38 smcginnis dims: Looks like a good plan.
20:54:48 clarkb mtreinish: looks like a source of a localrc in 50_neutron/upgrade.sh unsets USE_SYSTEMD
20:56:58 clarkb mtreinish: I see it, patch in a sec
20:58:35 dims smcginnis : updated 493380 (WIP) and rechecked 493057
21:00:10 smcginnis dims: Great, fingers crossed.
21:00:20 clarkb mtreinish: https://review.openstack.org/493673 that will likely need to depends on a grenade change that removes ensure_logs_exist then after those two go in add back in journald checking
21:01:27 mtreinish clarkb: just approved it
21:01:45 mtreinish we can rebase dim's grenade branch, or just wait
21:01:47 clarkb mtreinish: well it will fail grenade I think due to ensure_logs_exist
21:01:57 smcginnis dims: Hmm, doesn't seem right that cinder.conf transport_url would need to be changed to a nova_cell.
21:02:28 mtreinish clarkb: hmm, that's a good point. Let's see how it turns out
21:06:21 dims mtreinish : please don't rebase :)
21:10:57 mtreinish clarkb: https://review.openstack.org/#/c/493677/ should remove the ensure logs calls
21:11:36 clarkb mtreinish: do you want me to go ahead nad depend on that now or wait for mine to fail on those checks to confirm they will cause problems first?
21:12:26 mtreinish clarkb: probably better to wait and update, just in case we don't actually need it
21:12:51 clarkb ok
21:17:07 openstackgerrit Michael Still proposed openstack/nova master: WIP: Read from console ptys using privsep. https://review.openstack.org/489486
21:19:53 openstackgerrit Michael Still proposed openstack/nova master: WIP: Read from console ptys using privsep. https://review.openstack.org/489486
21:24:13 openstackgerrit Merged openstack/nova master: doc: Extend nfv feature matrix with pinning/NUMA https://review.openstack.org/327126
22:06:37 clarkb mtreinish: http://logs.openstack.org/73/493673/1/check/gate-grenade-dsvm-neutron-ubuntu-xenial/7e5d3b8/logs/grenade.sh.txt.gz#_2017-08-14_21_57_18_157 it failed as expected, adding the depends-on now
22:07:24 mtreinish clarkb: ok cool, I'll fast approve both after your respin
22:07:57 mtreinish unless dansmith wants to review the grenade side patch
22:12:07 dansmith mtreinish: review which?
22:12:59 mtreinish dansmith: https://review.openstack.org/493677
22:13:54 dansmith mtreinish: ah okay.. you want me to +2+W that?
22:14:01 mtreinish dansmith: sure
22:14:02 dansmith I trust your logic
22:16:13 mtreinish dansmith: modifiy isn't a real word? :)
22:17:01 dansmith mtreinish: modif-i-y like d-i-y maybe.. you could make up a definition
22:23:49 clarkb mtreinish: dansmith hrm http://logs.openstack.org/73/493673/1/check/gate-grenade-dsvm-neutron-ubuntu-xenial/7e5d3b8/logs/old/screen-q-l3.txt.gz is not how I expected it, I expected that to go in journald
22:24:07 clarkb so maybe that devstack change isn't quite what we need either, but in any case we definitely need to not error on missing log files while we sort this out
22:25:34 mtreinish clarkb: could it be d-g doing the collection?
22:25:37 clarkb heh that is beacuse base branch was ocata in that change
22:25:42 clarkb not pike
22:25:45 mtreinish ah, ok
22:26:00 clarkb so there may be an ordering here was need to accomodate, but I think change is otherwise sound
22:26:21 clarkb how did that other job end up being pike to master?
22:28:00 clarkb mtreinish: https://review.openstack.org/#/c/493057/11/devstack-vm-gate-wrap.sh I think we want to depends on that change as well?
22:28:15 clarkb and just live with the weirdness until ^ is in
22:31:02 smcginnis clarkb: Yep, that patch is what sets up the pike to master. ^
22:31:20 clarkb ok let me push a depends on that too and we'll just live with it a bit
22:31:42 clarkb oh wait we already did it the othe rway around
22:31:46 clarkb in that case onward :)
22:32:04 smcginnis clarkb: Or it can be rebased. Whatever makes it easier to figure out the right way here.
22:32:26 clarkb no thats fine they are in different repos so depends-on is what works
22:32:35 openstackgerrit Michael Still proposed openstack/nova master: WIP: Read from console ptys using privsep. https://review.openstack.org/489486
22:53:29 clarkb mtreinish: smcginnis also is this going to be a place where we need rolling changes to grenade?
22:53:42 clarkb I guess not becuse we only check logs on the target size
22:53:44 clarkb *side
22:53:55 smcginnis clarkb: Seems like we should.
22:54:28 clarkb smcginnis: I think we may get away with it because only the new/target side is being checkedwhich means running master of grenade anyways
22:56:37 openstackgerrit Merged openstack/nova master: Always use application/json accept header in report client https://review.openstack.org/489772
23:17:29 openstackgerrit Eric Fried proposed openstack/nova master: [Trivial] docstrings, typos, minor refactoring https://review.openstack.org/493701
23:29:19 openstackgerrit Eric Fried proposed openstack/nova master: Use ksa adapter for placement conf & requests https://review.openstack.org/492247
23:29:19 openstackgerrit Eric Fried proposed openstack/nova master: nova.utils.get_ksa_adapter() https://review.openstack.org/488137
#openstack-nova - 2017-08-16
01:46:24 openstackgerrit Naichuan Sun proposed openstack/nova master: xenapi: cached images should be cleaned up by time https://review.openstack.org/465954
02:07:28 dims dansmith : melwitt : around? i am chasing a problem with grenade pike->master, nova is ending up creating 2 ports and tempest ends with SSH timeout (base smoke test)
02:08:04 dims dansmith : melwitt : kevinbenton helped go through the logs and saw 2 ports getting created - detail/chat is here - http://paste.openstack.org/show/618473/
02:08:38 dims dansmith : melwitt : short version, when the instance gets rescheduled things go wrong
02:09:51 dims smcginnis : clarkb : here's the latest ^
02:15:24 clarkb and the test fails because the vm only brings up one interface and the floating IP is attached to the other
02:16:11 melwitt dims: I don't have time to look into it right now but fyi this has come up in the past if it might help https://bugs.launchpad.net/nova/+bug/1609526
02:16:13 openstack Launchpad bug 1639230 in nova (Ubuntu Xenial) "duplicate for #1609526 reschedule fails with ip already allocated error" [Undecided,New] - Assigned to Felipe Reyes (freyes)
02:16:48 melwitt or this. I don't know if it's the same thing you're seeing https://bugs.launchpad.net/nova/+bug/1639230
02:16:49 openstack Launchpad bug 1639230 in nova (Ubuntu Xenial) "reschedule fails with ip already allocated error" [Undecided,New] - Assigned to Felipe Reyes (freyes)
02:17:25 gaoyuan Hi, everyone. I met a problem. Please help if you can. The desc is simple. When I shut down a vm, it sometimes got start up automatically by nova-compute
02:17:36 gaoyuan Anyone met the same problem before?
02:17:49 gaoyuan I was using liberty, when met this problem.
02:47:12 openstackgerrit jichenjc proposed openstack/nova master: update comment for dropping support https://review.openstack.org/494061
03:35:48 openstackgerrit Kevin Zhao proposed openstack/nova master: Make uefi as the default boot perproties for AArch64 https://review.openstack.org/489951
06:35:38 openstackgerrit Maciej Jozefczyk proposed openstack/nova master: Remove host filter for _cleanup_running_deleted_instances periodic task https://review.openstack.org/491808
07:26:14 jaypipes gibi: good morning sir. any new bugs today?
07:26:32 gibi jaypipes: good morning
07:27:11 gibi jaypipes: no new bug today. yet. I have the evacuate and the shelve offload fix proposed if you have time to look at some reviews
07:27:18 openstackgerrit zhangbailin proposed openstack/nova-specs master: Modify spelling error in nova-spec document https://review.openstack.org/494094
07:28:12 gibi jaypipes: shelve offload regression + bugfix https://review.openstack.org/#/c/493062/
07:28:55 gibi jaypipes: I've just noticed that the evac bugfix needs a rebase https://review.openstack.org/#/c/493037/
07:29:01 gibi doing that right now
07:30:58 gibi jaypipes: yesterday I started looking at the soft delete and periodic reclaim case but no definit result yet if there is a bug or not
07:32:47 jaypipes gibi: k, reviewing. even though I hate shelving and all that it entails :)
07:35:56 openstackgerrit Balazs Gibizer proposed openstack/nova master: delete allocation of evacuated instance https://review.openstack.org/493037
07:36:17 gibi jaypipes: thanks. I share your feelings about shelve.
07:46:26 jaypipes gibi: k, https://review.openstack.org/#/c/493062/ reviewed.
07:46:36 jaypipes moving on to https://review.openstack.org/#/c/493834/
07:47:56 openstackgerrit zhangbailin proposed openstack/nova-specs master: Modify spelling error in nova-specs document https://review.openstack.org/494094
07:48:22 gibi jaypipes: thanks, I'm going to check your comments
07:49:49 jaypipes gibi: ok, so let's chat about Ia93168b1560267178059284186fb2b7096c7e81f
07:50:11 gibi jaypipes: sure
07:50:21 jaypipes gibi: it makes me uneasy (and probably dansmith too) to add code to the compute manager to directly call the scheduler report client from the compute manager
07:51:25 gibi jaypipes: should that code moved in to resource_tracker?
07:51:27 jaypipes gibi: I understand why you'd want to do this that way, though (to isolate when the delete_allocation_for_instance() method is called to only be during shelve_offloading() instead of trying to reconcile these things in the perioidic interval task of the RT
07:53:14 gibi jaypipes: do you suggest to try to integrate it to _update_usage_from_instance ? https://github.com/openstack/nova/blob/master/nova/compute/resource_tracker.py#L1012
07:54:19 jaypipes gibi: no, that method is already trying to do too much :)
07:54:32 gibi jaypipes: agree
07:54:48 jaypipes gibi: my guess is that for shelve_offloaded instances, the periodic interval is going to hit this code block here: https://github.com/openstack/nova/blob/master/nova/compute/resource_tracker.py#L1183
07:55:12 jaypipes gibi: because instance.host has not yet been un-set and the allocation for the instance is going to be still in the placmeent API

Earlier   Later