Earlier  
Posted Nick Remark
#openstack-nova - 2023-05-06
08:55:44 manuvakery1 Hi while running nova online-data-migration I am getting following error
08:55:47 manuvakery1 2023-05-06 07:54:26.277 256132 ERROR nova.cmd.manage found, done = migration_meth(ctxt, count)
08:55:47 manuvakery1 2023-05-06 07:54:26.277 256132 ERROR nova.cmd.manage File "/usr/lib/python2.7/site-packages/nova/objects/request_spec.py", line 732, in migrate_instances_add_request_spec
08:55:47 manuvakery1 2023-05-06 07:54:26.277 256132 ERROR nova.cmd.manage [req-0d649e34-56ab-4f5e-8f3b-2a062097a702 - - - - -] Error attempting to run <function migrate_instances_add_request_spec at 0x7facf137a500>: AttributeError: 'NoneType' object has no attribute 'hosts'
08:55:47 manuvakery1 2023-05-06 07:54:26.277 256132 ERROR nova.cmd.manage Traceback (most recent call last):
08:55:47 manuvakery1 2023-05-06 07:54:26.277 256132 ERROR nova.cmd.manage File "/usr/lib/python2.7/site-packages/nova/cmd/manage.py", line 679, in _run_migration
08:55:48 manuvakery1 2023-05-06 07:54:26.277 256132 ERROR nova.cmd.manage _create_minimal_request_spec(context, instance)
08:55:48 manuvakery1 2023-05-06 07:54:26.277 256132 ERROR nova.cmd.manage File "/usr/lib/python2.7/site-packages/nova/objects/request_spec.py", line 705, in _create_minimal_request_spec
08:55:50 manuvakery1 2023-05-06 07:54:26.277 256132 ERROR nova.cmd.manage scheduler_utils.setup_instance_group(context, request_spec)
08:55:50 manuvakery1 2023-05-06 07:54:26.277 256132 ERROR nova.cmd.manage File "/usr/lib/python2.7/site-packages/nova/scheduler/utils.py", line 890, in setup_instance_group
08:55:52 manuvakery1 2023-05-06 07:54:26.277 256132 ERROR nova.cmd.manage request_spec.instance_group.hosts = list(group_info.hosts)
08:55:52 manuvakery1 2023-05-06 07:54:26.277 256132 ERROR nova.cmd.manage AttributeError: 'NoneType' object has no attribute 'hosts'
08:55:54 manuvakery1 2023-05-06 07:54:26.277 256132 ERROR nova.cmd.manage
08:55:54 manuvakery1 2023-05-06 07:54:26.777 256132 ERROR nova.objects.keypair [req-0d649e34-56ab-4f5e-8f3b-2a062097a702 - - - - -] Some instances are still missing keypair information. Unable to run keypair migration at this time.
08:56:10 manuvakery1 what am I missing here
09:54:27 manuvakery1 Ignore it worked after deleting some broken instances
#openstack-nova - 2023-05-07
01:11:45 opendevreview Takashi Natsume proposed openstack/placement master: Fix a wrong assertion method https://review.opendev.org/c/openstack/placement/+/861489
01:12:15 opendevreview Takashi Natsume proposed openstack/nova master: Update contributor guide for 2023.2 Bobcat https://review.opendev.org/c/openstack/nova/+/876447
#openstack-nova - 2023-05-08
04:58:43 opendevreview Amit Uniyal proposed openstack/nova master: WIP: Delete dangling bdms https://review.opendev.org/c/openstack/nova/+/882284
08:56:51 opendevreview Balazs Gibizer proposed openstack/nova stable/2023.1: Reproduce asym NUMA mixed CPU policy bug https://review.opendev.org/c/openstack/nova/+/882508
08:56:52 opendevreview Balazs Gibizer proposed openstack/nova stable/2023.1: Handle zero pinned CPU in a cell with mixed policy https://review.opendev.org/c/openstack/nova/+/882509
08:57:59 opendevreview Balazs Gibizer proposed openstack/nova stable/zed: Reproduce asym NUMA mixed CPU policy bug https://review.opendev.org/c/openstack/nova/+/882530
08:58:00 opendevreview Balazs Gibizer proposed openstack/nova stable/zed: Handle zero pinned CPU in a cell with mixed policy https://review.opendev.org/c/openstack/nova/+/882531
08:59:16 opendevreview Balazs Gibizer proposed openstack/nova stable/yoga: Reproduce asym NUMA mixed CPU policy bug https://review.opendev.org/c/openstack/nova/+/882532
08:59:17 opendevreview Balazs Gibizer proposed openstack/nova stable/yoga: Handle zero pinned CPU in a cell with mixed policy https://review.opendev.org/c/openstack/nova/+/882533
09:00:07 opendevreview Balazs Gibizer proposed openstack/nova stable/xena: Reproduce asym NUMA mixed CPU policy bug https://review.opendev.org/c/openstack/nova/+/882534
09:00:08 opendevreview Balazs Gibizer proposed openstack/nova stable/xena: Handle zero pinned CPU in a cell with mixed policy https://review.opendev.org/c/openstack/nova/+/882535
09:01:42 opendevreview Balazs Gibizer proposed openstack/nova stable/wallaby: Reproduce asym NUMA mixed CPU policy bug https://review.opendev.org/c/openstack/nova/+/882536
09:01:42 opendevreview Balazs Gibizer proposed openstack/nova stable/wallaby: Handle zero pinned CPU in a cell with mixed policy https://review.opendev.org/c/openstack/nova/+/882537
09:03:51 opendevreview Danylo Vodopianov proposed openstack/nova master: Napatech SmartNIC support https://review.opendev.org/c/openstack/nova/+/859577
09:44:12 kashyap dansmith: When you're about - I added "Affects" "kernel-package (Ubuntu)" here: https://bugs.launchpad.net/ubuntu/+source/kernel-package/+bug/2018612
09:44:50 kashyap Added some environment details, and I also just asked on #ubunutu-kernel to make sure it's the right package name.
10:03:46 opendevreview Amit Uniyal proposed openstack/nova master: WIP: Delete dangling bdms https://review.opendev.org/c/openstack/nova/+/882284
11:55:57 kashyap dansmith: Folks from #ubuntu-kernel say that the kernel in the CirrOS 0.5.2 image is unsupported.
11:56:38 kashyap The kernel ("5.3.0-26-generic") from CirrOS 0.5.2 _used_ to be LTS; but right now it's 5.4 (from Focal).
11:59:00 kashyap I'll ask the person responding to also respond on the bug
12:11:37 kashyap dansmith: So that was the current diagnosis from #ubuntu-kernel folks:
12:11:43 kashyap CirrOS 0.5.1 was built in march 2020, before Focal release, which can explain the 5.3 kernel [that is crashing]. And CirrOS 0.5.2 didn't upgrade the kernel.
12:18:24 kgube Hi bauzas, could you have another look at this? https://review.opendev.org/c/openstack/nova-specs/+/877233
12:28:29 kashyap dansmith: I'm filing a CirrOS 0.5.2 issue to refresh the image and update the packages.
12:30:03 ykarel just in case there is an image cirros 0.6.0/0.6.1 if that helps
12:30:45 kashyap ykarel: Yeah; I know it's there. But we're trying to tackle a specific issue w/ 0.5.2 :)
12:31:11 ykarel ack :)
12:42:53 opendevreview Merged openstack/placement master: Fix a wrong assertion method https://review.opendev.org/c/openstack/placement/+/861489
12:48:27 kashyap dansmith: And that's the CirrOS issue I filed: https://github.com/cirros-dev/cirros/issues/102
12:49:41 kashyap (More details in the Nova bug you filed)
13:04:53 kashyap sean-k-mooney[m]: As promised, the Ubunutu folks picked up my device-detach backport request; and 'paelzer' (Christian Ehrhardt) filed a tracker on my behalf: https://bugs.launchpad.net/ubuntu/+source/qemu/+bug/2018733/
13:16:33 dansmith kashyap: ack, cool, I know we have a todo to upgrade to 6.x but I think there are other factors at play
13:46:43 dansmith gouthamr: I created this https://review.opendev.org/c/openstack/devstack-plugin-ceph/+/882483 to try to convert our live migration multinode job over to cephadm, but it looks like the two nodes aren't setup properly
13:47:08 dansmith gouthamr: that might require some help from a more ceph-literate person than me
13:48:49 dansmith they have different mon_host and fsid values, which I assume is .. not right
14:00:28 kashyap dansmith: Oh, good to know - if there's already an infra TODO to update to 0.6.x (CirrOS)
14:06:29 dansmith it was actually bauzas that had the patch up IIRC
14:10:38 opendevreview Danylo Vodopianov proposed openstack/nova-specs master: Add support for Napatech LinkVirt SmartNICs https://review.opendev.org/c/openstack/nova-specs/+/859290
15:31:38 gouthamr hi dansmith: yes, "REMOTE_CEPH" doesn't work with cephadm; on multi-node you'd need that..
15:32:04 dansmith gouthamr: ah, I see that's the other .. yeah, that patch
15:32:18 dansmith okay cool, well, we probably need to get that resolved before you drop the non-cephadm stuff
15:32:42 gouthamr yep
23:03:34 opendevreview Dan Smith proposed openstack/nova master: Populate ComputeNode.service_id https://review.opendev.org/c/openstack/nova/+/879904
23:03:35 opendevreview Dan Smith proposed openstack/nova master: Add compute_id columns to instances, migrations https://review.opendev.org/c/openstack/nova/+/879499
23:03:35 opendevreview Dan Smith proposed openstack/nova master: Add dest_compute_id to Migration object https://review.opendev.org/c/openstack/nova/+/879682
23:03:36 opendevreview Dan Smith proposed openstack/nova master: Add compute_id to Instance object https://review.opendev.org/c/openstack/nova/+/879500
23:03:36 opendevreview Dan Smith proposed openstack/nova master: Online migrate missing Instance.compute_id fields https://review.opendev.org/c/openstack/nova/+/879905
#openstack-nova - 2023-05-09
01:12:51 opendevreview sean mooney proposed openstack/os-vif master: [WIP] set default qos policy https://review.opendev.org/c/openstack/os-vif/+/881751
05:30:02 han-guangyu hello, I created instance by ISO image. Installing system to a cinder volume.
05:30:59 han-guangyu But after instance reboot, instance still enter the system installation interface
05:30:59 han-guangyu But after instance reboot, instance still enter the system installation interface
05:31:27 han-guangyu I know I can detach the volume, create a new instance
05:32:02 han-guangyu I would like to ask, is there a way to make this instance, after restarting, use the volume installed with the system as the startup item
05:32:24 han-guangyu Similar to libvirt, after installing the operating system with iso, it will automatically restart and enter the system
05:33:16 han-guangyu Or if I want to try to achieve this requirement through small changes in a private environment, any suggestions?
05:33:23 han-guangyu thanks for any help
12:46:39 opendevreview Merged openstack/nova master: Handle zero pinned CPU in a cell with mixed policy https://review.opendev.org/c/openstack/nova/+/862687
12:57:17 sean-k-mooney yey :)
13:35:03 opendevreview Danylo Vodopianov proposed openstack/nova master: Napatech SmartNIC support https://review.opendev.org/c/openstack/nova/+/859577
13:44:36 opendevreview Sahid Orentino Ferdjaoui proposed openstack/nova master: wip: convert usage of neutronclient to openstacksdk https://review.opendev.org/c/openstack/nova/+/882714
13:51:29 opendevreview Amit Uniyal proposed openstack/nova master: WIP: Added api for healthcheck https://review.opendev.org/c/openstack/nova/+/882718
14:00:34 opendevreview Merged openstack/nova stable/2023.1: Reproduce bug 1995153 https://review.opendev.org/c/openstack/nova/+/882313
14:36:36 opendevreview ribaudr proposed openstack/nova master: Attach Manila shares via virtiofs (db) https://review.opendev.org/c/openstack/nova/+/831193
14:36:36 opendevreview ribaudr proposed openstack/nova master: Attach Manila shares via virtiofs (objects) https://review.opendev.org/c/openstack/nova/+/839401
14:36:37 opendevreview ribaudr proposed openstack/nova master: Attach Manila shares via virtiofs (manila abstraction) https://review.opendev.org/c/openstack/nova/+/831194
14:36:37 opendevreview ribaudr proposed openstack/nova master: Attach Manila shares via virtiofs (drivers and compute manager part) https://review.opendev.org/c/openstack/nova/+/833090
14:36:38 opendevreview ribaudr proposed openstack/nova master: Attach Manila shares via virtiofs (api) https://review.opendev.org/c/openstack/nova/+/836830
14:36:38 opendevreview ribaudr proposed openstack/nova master: Check shares support https://review.opendev.org/c/openstack/nova/+/850499
14:36:39 opendevreview ribaudr proposed openstack/nova master: Add metadata for shares https://review.opendev.org/c/openstack/nova/+/850500
14:36:39 opendevreview ribaudr proposed openstack/nova master: Add instance.share_attach notification https://review.opendev.org/c/openstack/nova/+/850501
14:36:40 opendevreview ribaudr proposed openstack/nova master: Add instance.share_detach notification https://review.opendev.org/c/openstack/nova/+/851028
14:36:41 opendevreview ribaudr proposed openstack/nova master: Add shares to InstancePayload https://review.opendev.org/c/openstack/nova/+/851029
14:36:41 opendevreview ribaudr proposed openstack/nova master: Add helper methods to attach/detach shares https://review.opendev.org/c/openstack/nova/+/852085
14:36:43 opendevreview ribaudr proposed openstack/nova master: Add libvirt test to ensure metadata are working. https://review.opendev.org/c/openstack/nova/+/852086
14:36:43 opendevreview ribaudr proposed openstack/nova master: Add virt/libvirt error test cases https://review.opendev.org/c/openstack/nova/+/852087
14:36:45 opendevreview ribaudr proposed openstack/nova master: Add share_info parameter to reboot method for each driver (driver part) https://review.opendev.org/c/openstack/nova/+/854823
14:36:45 opendevreview ribaudr proposed openstack/nova master: Support rebooting an instance with shares (compute and API part) https://review.opendev.org/c/openstack/nova/+/854824
14:36:47 opendevreview ribaudr proposed openstack/nova master: Add instance.share_attach_error notification https://review.opendev.org/c/openstack/nova/+/860282
14:36:47 opendevreview ribaudr proposed openstack/nova master: Add instance.share_detach_error notification https://review.opendev.org/c/openstack/nova/+/860283
14:36:49 opendevreview ribaudr proposed openstack/nova master: Add share_info parameter to resume method for each driver (driver part) https://review.opendev.org/c/openstack/nova/+/860284
14:36:49 opendevreview ribaudr proposed openstack/nova master: Support resuming an instance with shares (compute and API part) https://review.opendev.org/c/openstack/nova/+/860285
14:36:51 opendevreview ribaudr proposed openstack/nova master: Add helper methods to rescue/unrescue shares https://review.opendev.org/c/openstack/nova/+/860286
14:36:51 opendevreview ribaudr proposed openstack/nova master: Support rescuing an instance with shares (driver part) https://review.opendev.org/c/openstack/nova/+/860287
14:36:53 opendevreview ribaudr proposed openstack/nova master: Support rescuing an instance with shares (compute and API part) https://review.opendev.org/c/openstack/nova/+/860288

Earlier   Later