Earlier  
Posted Nick Remark
#openstack-nova - 2022-11-28
17:19:45 bauzas I can try to recheck my original patch
17:19:56 bauzas ralonsoh: kudos to the neutron team
17:20:00 ralonsoh yw
17:25:01 sean-k-mooney ralonsoh ah an ye removed the config option great
17:25:06 sean-k-mooney then it should just work
17:25:15 sean-k-mooney without us needing to modify jobs
17:25:20 ralonsoh yes referring to the Nova patch
17:26:08 bauzas ralonsoh: sean-k-mooney: I just rechecked https://review.opendev.org/c/openstack/nova/+/838976/8
17:26:12 bauzas we will see
17:26:24 ralonsoh bauzas, I'll keep an eye on it
17:26:39 sean-k-mooney bauzas: we still need to skip the lvm tests
17:26:41 sean-k-mooney right
17:26:43 bauzas either way, it will fail due to the nova-lvm issue but we'll see whether ovn and nova-next jobs work
17:26:50 bauzas sean-k-mooney: yup
17:27:04 bauzas this is just for checking against something which is not my skiptest patch
17:27:17 sean-k-mooney ya ok well it might pass put its unlikely to do it twice to get passed both gate and check
17:27:28 bauzas yup
17:27:39 bauzas nova-lvm seems to fail 100% of times
17:29:19 sean-k-mooney is nova-lvm using pc or q35 by the way i assume pc
17:30:33 sean-k-mooney the ohter thing we could try is putting it back to focal temporilly
17:30:53 sean-k-mooney thats more invasive however then skiping the flaky tests
17:31:42 sean-k-mooney not set in the nova.conf so it should be pc
17:31:49 sean-k-mooney https://zuul.opendev.org/t/openstack/build/f076244738904c949e63b21571a5fc9a/log/controller/logs/etc/nova/nova-cpu_conf.txt#118
17:46:11 opendevreview Amit Uniyal proposed openstack/nova stable/train: Adds a repoducer for post live migration fail https://review.opendev.org/c/openstack/nova/+/863806
17:46:12 opendevreview Amit Uniyal proposed openstack/nova stable/train: [compute] always set instance.host in post_livemigration https://review.opendev.org/c/openstack/nova/+/864055
17:57:40 gmann gibi: bauzas sean-k-mooney: hi, for detach issue in nova-lvm job. tempest patch need more time it seems. I was making server sshable by default which need more work in other tests.
17:58:55 gmann gibi: sean-k-mooney bauzas: I am moving my house this week so might need some more time on that. For now, I think we can go with skipping the failing tests temporarily in nova-lvm
17:59:06 bauzas ack
17:59:09 opendevreview Amit Uniyal proposed openstack/nova stable/ussuri: [compute] always set instance.host in post_livemigration https://review.opendev.org/c/openstack/nova/+/864007
17:59:15 gibi gmann: thanks for looking into it
18:00:54 sean-k-mooney so i think we shoudl be ok to skip them for a few weeks to unblock things
18:01:16 gibi yepp I agree
18:01:25 sean-k-mooney the cidner code paths really shoudl not depend on the images_backend that is in use at least not lvm
18:01:26 gibi sady we have no better option now
18:01:29 gmann but thing is those failing rescue test, all use ssh-able server. there is something else might be causing the failure
18:01:45 sean-k-mooney gmann: yep there likely is
18:01:55 gmann something to do on Jammy as lvm on focal working fine
18:02:11 sean-k-mooney possibly
18:02:28 sean-k-mooney it defiently happens more on jammy im not sure it would not happen on focal
18:02:43 sean-k-mooney it might be related to a default config delta between the two or the qemu/libvirt verions
18:02:59 gmann may be
18:02:59 sean-k-mooney but we dont currently have a lot of capsity to investigate
18:03:40 gmann yeah, do we have patch up to skip the tests?
18:04:05 sean-k-mooney i think bauzas has one but im not sure they updated for the volume tests
18:04:19 gmann k
18:04:51 gmann this one? https://review.opendev.org/c/openstack/nova/+/865658
18:05:13 sean-k-mooney that was to solve the other issue so that is not needed
18:05:14 gmann this does not include nova-lvm failing tests
18:05:21 gmann k
18:05:23 sean-k-mooney we shoudl pull that form the gate
18:06:22 sean-k-mooney gmann: i do not see one form sylvain
18:06:38 sean-k-mooney so i guess there is non e right now for the lvm failures
18:11:45 opendevreview Amit Uniyal proposed openstack/nova stable/train: [compute] always set instance.host in post_livemigration https://review.opendev.org/c/openstack/nova/+/864055
23:59:23 opendevreview Ghanshyam proposed openstack/nova master: Temporary skip some volume detach test in nova-lvm job https://review.opendev.org/c/openstack/nova/+/865922
#openstack-nova - 2022-11-29
02:38:23 opendevreview Amit Uniyal proposed openstack/nova stable/train: Adds a repoducer for post live migration fail https://review.opendev.org/c/openstack/nova/+/863806
02:38:24 opendevreview Amit Uniyal proposed openstack/nova stable/train: [compute] always set instance.host in post_livemigration https://review.opendev.org/c/openstack/nova/+/864055
02:43:59 gmann bauzas: sean-k-mooney[m] gibi : this is for skipping failing tests https://review.opendev.org/c/openstack/nova/+/865922
08:38:39 opendevreview Amit Uniyal proposed openstack/nova master: Refactoring live_migrate function name https://review.opendev.org/c/openstack/nova/+/865954
08:41:46 bauzas gibi: sean-k-mooney: your help is appreciated https://review.opendev.org/c/openstack/nova/+/865922
09:30:33 opendevreview Arnaud Morin proposed openstack/nova master: Unbind port when offloading a shelved instance https://review.opendev.org/c/openstack/nova/+/853682
09:34:08 gibi bauzas: on it
09:34:56 gibi gmann: thank you
09:45:27 bauzas gibi: thanks
09:45:38 bauzas and I updated the ML thread to notify our gerrit users
09:45:50 gibi cool
09:45:50 opendevreview Amit Uniyal proposed openstack/nova master: Adds check if resized to swap zero https://review.opendev.org/c/openstack/nova/+/857339
11:08:30 opendevreview Merged openstack/nova master: Temporary skip some volume detach test in nova-lvm job https://review.opendev.org/c/openstack/nova/+/865922
11:08:37 opendevreview Merged openstack/nova stable/wallaby: Adds a repoducer for post live migration fail https://review.opendev.org/c/openstack/nova/+/863900
11:13:34 opendevreview Manuel Bentele proposed openstack/nova-specs master: Add configuration options to set SPICE compression settings https://review.opendev.org/c/openstack/nova-specs/+/849488
11:13:44 opendevreview Amit Uniyal proposed openstack/nova stable/train: add regression test case for bug 1978983 https://review.opendev.org/c/openstack/nova/+/864168
11:13:45 opendevreview Amit Uniyal proposed openstack/nova stable/train: For evacuation, ignore if task_state is not None https://review.opendev.org/c/openstack/nova/+/864169
11:40:23 opendevreview Amit Uniyal proposed openstack/nova stable/train: add regression test case for bug 1978983 https://review.opendev.org/c/openstack/nova/+/864168
11:40:24 opendevreview Amit Uniyal proposed openstack/nova stable/train: For evacuation, ignore if task_state is not None https://review.opendev.org/c/openstack/nova/+/864169
12:01:34 opendevreview Merged openstack/nova stable/wallaby: [compute] always set instance.host in post_livemigration https://review.opendev.org/c/openstack/nova/+/863901
13:45:30 sahid morning dansmith, how do you feel regarding spec https://review.opendev.org/c/openstack/nova-specs/+/857838 I also have proposed the implementation
13:46:04 sahid if you have a moment i would be glad to make progress on it, eel free to let me know if there is any point that you need details thanks a lot
13:47:00 slaweq gibi bauzas and other nova cores: hi, please check https://review.opendev.org/c/openstack/nova/+/855664 when You will have few minutes, thx in advance
13:48:12 pengo_ Hello I am using wallaby release openstack and having issues with cinder volumes attachments as once I try to delete, resize or unshelve the shelved vms the volume_attachement entries do not get deleted in cinder db and therefore the above mentioned operations fail every time. I have to delete these volume_attachement entries manually to make it work. I could only gather logs from nova-compute
13:48:12 pengo_ https://www.irccloud.com/pastebin/kIDKAF54/
13:49:54 pengo_ If I would like to unshelve the instance it wont work as it has a duplicate entry in cinder db for the attachment. So i have to delete it manually from db or via cli. This is the only choice I have if I would like to unshelve vm. But this is not a good approach for production env to delete duplicate volume attachments entries every time for every vm. Is there any way to fix this issue ?
14:11:22 opendevreview Amit Uniyal proposed openstack/nova master: Adds regression functional test for 1980720 https://review.opendev.org/c/openstack/nova/+/861357
14:11:23 opendevreview Amit Uniyal proposed openstack/nova master: Adds check for VM snapshot fail while quiesce https://review.opendev.org/c/openstack/nova/+/852171
14:16:04 bauzas slaweq: hah, I remember the context, we discussed this at the PTG right?
14:22:33 pengo_ lyes
14:35:22 slaweq_ bauzas: yes, we talked about it at the PTG
14:35:40 slaweq_ and we agreed that we can go with this approach
14:36:40 sean-k-mooney is this related to the mtu advertisement ?
14:36:46 sean-k-mooney or soemthing else
14:37:00 sean-k-mooney ah yes https://review.opendev.org/c/openstack/nova/+/855664
14:37:14 slaweq_ sean-k-mooney: yes
14:37:29 sean-k-mooney ya so we agreeed that if dhcp is avialable on the subnet we can omit the mtu form the metadata
14:38:12 sean-k-mooney this will allow the mtu to be reduced but not increased and the vms will clamp the mtu the next time it renews its dhcp lease
14:38:19 sean-k-mooney will still not perfect it will help
14:38:57 sean-k-mooney i can take a look now before i forget about it again
14:41:23 sean-k-mooney slaweq_: quick question
14:42:00 sean-k-mooney slaweq_: is the mtu on the netowrk or on the subnet in neutron. its generally an aspect of the netwrok in a real deployment just wondering how its modeled in neutron
14:42:47 sean-k-mooney neutron does not supprot having diffenert mtu per network segment correct when using routed networks
14:47:44 sean-k-mooney i have asked that in the review https://review.opendev.org/c/openstack/nova/+/855664/3/nova/virt/netutils.py#b266
14:48:12 slaweq_ sean-k-mooney: mtu is per network for sure
14:48:26 slaweq_ I'm not sure about segments in routed networks

Earlier   Later