Earlier  
Posted Nick Remark
#openstack-nova - 2022-10-20
18:48:28 darkhorse I am trying to fix a nova issue that instance delete action log is not added when deleting a shelved_offloaded instance.
18:48:42 darkhorse https://review.opendev.org/c/openstack/nova/+/861951
18:49:26 darkhorse I committed the patchset but the CI build fails. Can anyone help figuring out why it fails?
18:59:46 frickler fyi I kind of answered the above in #openstack-dev
19:38:26 darkhorse @frickler
19:38:36 darkhorse Thank you for your information.
19:38:55 darkhorse How can I verify if the bug exists in master branch?
22:22:47 melwitt stephenfin: ack, I never noticed that before with argparse in general. looking at that stackoverflow, I believe I've seen the if len(args.things) > 1: raise error saying no repeats method before for handling that scenario
22:23:27 melwitt but it's good to know this is "expected behavior" from argparse
#openstack-nova - 2022-10-21
07:14:33 opendevreview Amit Uniyal proposed openstack/nova stable/yoga: Adds a repoducer for post live migration fail https://review.opendev.org/c/openstack/nova/+/861871
07:14:34 opendevreview Amit Uniyal proposed openstack/nova stable/yoga: [compute] always set instance.host in post_livemigration https://review.opendev.org/c/openstack/nova/+/861872
09:14:01 opendevreview Slawek Kaplonski proposed openstack/nova master: Don't provide MTU value in metadata service if DHCP is enabled https://review.opendev.org/c/openstack/nova/+/855664
09:41:06 opendevreview Amit Uniyal proposed openstack/nova stable/zed: Adds a repoducer for post live migration fail https://review.opendev.org/c/openstack/nova/+/861856
09:41:07 opendevreview Amit Uniyal proposed openstack/nova stable/zed: [compute] always set instance.host in post_livemigration https://review.opendev.org/c/openstack/nova/+/861857
09:46:57 opendevreview Amit Uniyal proposed openstack/nova stable/yoga: Adds a repoducer for post live migration fail https://review.opendev.org/c/openstack/nova/+/861871
12:52:18 opendevreview Amit Uniyal proposed openstack/nova stable/yoga: Adds a repoducer for post live migration fail https://review.opendev.org/c/openstack/nova/+/861871
12:52:19 opendevreview Amit Uniyal proposed openstack/nova stable/yoga: [compute] always set instance.host in post_livemigration https://review.opendev.org/c/openstack/nova/+/861872
13:01:31 bauzas reminder : we start now our last PTG day, just sayin' :)
13:03:26 sean-k-mooney oh
13:03:34 sean-k-mooney ah ill get coffee then join
13:03:40 sean-k-mooney feel free to start without me
13:03:46 sean-k-mooney ill be 5 minutes
13:03:49 bauzas cool
13:55:17 bauzas stephenfin: we're about to discuss your OSC topic next in a second
13:56:03 stephenfin bauzas: I'm in the SDK/OSC session :( Can you take notes and I can address async?
13:56:21 bauzas stephenfin: oh, when is this session done ?
13:56:30 stephenfin 1 hour
13:56:49 bauzas stephenfin: I see, ending at 3pm UTC ?
13:57:02 stephenfin yes
14:30:13 darkhorse Hi team
14:30:20 darkhorse File "/home/zuul/src/opendev.org/openstack/nova/nova/tests/fixtures/nova.py", line 224, in _poison_configure
14:30:21 darkhorse raise Exception('This test uses methods that set internal oslo_db '
14:30:21 darkhorse Exception: This test uses methods that set internal oslo_db state, but it does not claim to use the database. This will conflict with the setup of tests that do use the database and cause failures later.
14:31:18 darkhorse I have committed a patchset to fix the issue that I reported [here] (https://bugs.launchpad.net/nova/+bug/1993736)
14:31:49 darkhorse I am getting a CI build error above.
14:32:11 darkhorse What does that exception mean and how can I fix it?
14:33:11 gibi darkhorse: you have a unit test case that actaully try to hit the DB
14:33:46 gibi could you point to the failure in CI?
14:37:46 darkhorse yes my patch is trying to add delete action log for shelved instances. when an instance is deleted at shelved_offloaded state, delete action is not added to action-list.
14:38:08 darkhorse https://review.opendev.org/c/openstack/nova/+/861951
14:38:17 darkhorse here is the patchset
14:38:29 darkhorse and this is the failure in CI
14:38:37 darkhorse https://zuul.opendev.org/t/openstack/build/0ed00dd1d0354da9b7724f32339f063e
14:39:51 darkhorse gibi: thank you for replying to my questions.
14:43:28 gibi darkhorse: so that unit test case https://github.com/openstack/nova/blob/b1958b7cfa6b8aca5b76b3f133627bb733d29f00/nova/tests/unit/compute/test_api.py#L7908 is set up in a way that it mocks out every call that touches the DB. But the patch https://review.opendev.org/c/openstack/nova/+/861951 added a new call _record_action_start that is eventually write to the DB
14:45:59 gibi darkhorse: so you have to change the test to also mock _record_action_start
14:46:38 darkhorse gibi: will you point me how to do that?
14:47:21 gibi darkhorse: you can look at the other tests in https://github.com/openstack/nova/blob/b1958b7cfa6b8aca5b76b3f133627bb733d29f00/nova/tests/unit/compute/test_api.py#L7908 how mocking is doen
14:47:25 gibi done
14:47:50 gibi for example https://github.com/openstack/nova/blob/b1958b7cfa6b8aca5b76b3f133627bb733d29f00/nova/tests/unit/compute/test_api.py#L8090-L8102 is mocking _record_action_start
14:58:41 darkhorse gibi: thank you so much!!
15:23:51 bauzas thanks folks, was a productive PTG
15:37:56 gibi bauzas: thanks for running it
15:39:33 melwitt bauzas: thank you for connecting me with whoami-rajat for ptg, cinder team were able to fit me in the agenda and we had a good chat and a way forward
15:39:52 bauzas ++
17:02:19 whoami-rajat melwitt, thanks for joining and discussing it
17:02:46 melwitt ++
18:37:06 opendevreview Alex Chan proposed openstack/nova stable/xena: fix instance action log when deleting shelved instance https://review.opendev.org/c/openstack/nova/+/861951
19:14:12 opendevreview Erlon R. Cruz proposed openstack/nova stable/wallaby: Fix pre_live_migration rollback https://review.opendev.org/c/openstack/nova/+/836016
19:14:13 opendevreview Erlon R. Cruz proposed openstack/nova stable/wallaby: Adds regression test for bug LP#1944619 https://review.opendev.org/c/openstack/nova/+/862401
19:18:40 opendevreview Erlon R. Cruz proposed openstack/nova stable/wallaby: Adds regression test for bug LP#1944619 https://review.opendev.org/c/openstack/nova/+/838332
19:18:41 opendevreview Erlon R. Cruz proposed openstack/nova stable/wallaby: Fix pre_live_migration rollback https://review.opendev.org/c/openstack/nova/+/836016
20:14:24 opendevreview Alex Chan proposed openstack/nova master: record action log when deleting shelved instance https://review.opendev.org/c/openstack/nova/+/862404
#openstack-nova - 2022-10-22
02:19:04 opendevreview melanie witt proposed openstack/nova master: DNM testing images_type = raw with resize enabled https://review.opendev.org/c/openstack/nova/+/862416
02:21:15 opendevreview melanie witt proposed openstack/nova master: DNM testing images_type = raw with resize enabled https://review.opendev.org/c/openstack/nova/+/862416
07:01:41 opendevreview melanie witt proposed openstack/nova master: DNM testing images_type = raw with resize enabled https://review.opendev.org/c/openstack/nova/+/862416
13:03:34 opendevreview melanie witt proposed openstack/nova master: DNM testing images_type = raw with resize enabled https://review.opendev.org/c/openstack/nova/+/862416
#openstack-nova - 2022-10-24
09:34:57 opendevreview Sahid Orentino Ferdjaoui proposed openstack/nova master: compute: enhance compute evacuate instance to support target state https://review.opendev.org/c/openstack/nova/+/858383
09:34:58 opendevreview Sahid Orentino Ferdjaoui proposed openstack/nova master: api: extend evacuate instance to support target state https://review.opendev.org/c/openstack/nova/+/858384
09:54:16 sean-k-mooney1 sahid: ill try to summerise the ptg discussion on the spec review but when we discussed you feature we agreed on two high level things.
09:55:06 sean-k-mooney1 1.) we wont ask you to fix all the drivers to not start the vms, we will file that as an existing bug and adress that later although your free to do that too once your feature is complete
09:55:38 sean-k-mooney1 2.) we dont wat to add a new api parmater. instead we woudl prefer the new micro verion to just make evacuate always evacuate to powered off
09:57:52 sean-k-mooney sahid: what that means for you is all the rpc changes you made are still correct and can be resused but you do not need to add a new api parmater, the new microversion means set the target state to stopped and old means dont pass it for the rpc call.
09:58:11 sean-k-mooney ill summerise this in the spec later today
09:58:57 sean-k-mooney sahid: it was basicaly the last topic of the ptg https://etherpad.opendev.org/p/nova-antelope-ptg#L451
09:59:58 sahid_ sean-k-mooney: o/ I had some connectivty issues, sorry for that, could you copy/past your last messages addressed to me?
10:17:31 frickler sahid_: unless you are referring to private messages, you could also check the channel log at https://meetings.opendev.org/irclogs/%23openstack-nova/latest.log.html
12:18:01 sahid frickler: ack thanks
12:24:36 sahid sean-k-mooney: i see, so now the prefererenc for evacuate would be to always evacuate to shutoff, right?
12:26:41 sahid btw thank to give me the chance to not update all the virt drivers :-) Should I open the bug report or have you already assigned someone during PTG to open it?
12:45:05 rm_work hey, hoping someone can help me understand how the fault reporting system works when retries are enabled... it seems like the "fault" field always just says "MaxRetriesExceeded" and gives that traceback, when I'd hope to be able to see the REASON for the failure (at least the latest failure)?
12:45:39 rm_work I am not sure how that would work, but I'm sure there must be some way to make that happen (and maybe we messed it up internally) because otherwise the "fault" field seems like it'd be pretty useless?
12:48:36 rm_work or maybe I'm expecting the wrong thing here, maybe that's right depending on the type of error?
12:52:23 rm_work I guess it's storing each fault in the DB on the server object somehow when it happens, so it'd be the last failure recorded that gets shown in the `server show` return?
13:01:55 sean-k-mooney sahid: we kind of felt it would be unfair to ask you do do that since its not actully required for your feature. its more just existing tech debt. sure please feel free to file one if not i can do it later. and yes the prefecne is to always evacuate to off when using the new microversion
13:02:51 sean-k-mooney baiscally because of a data integrety, power usage and encypted voluems we felt it would be better to alwasy evacuate as off
13:03:37 sean-k-mooney since evacuate is an admin only opeartion its not reasonable to assume the admin knows if its safe to restart the workload or not escially since there may be a posiablity of data curruption depending on howt eh host fails
13:04:04 sean-k-mooney so if we alwasy evacuate to off then the enduser who should know can decied if they want to start, rescue or delete the instace
13:05:02 sean-k-mooney sahid: for the encypted volume case it would be niceif you could handel and ignore the excption we get during spawn but that can be a follow up patch
13:05:48 sean-k-mooney sahid: evenutlaly we woudl like to split up rebuild/evacuate int 3 steps internally. 1 stop the instace, 2 rebuild the disk, 3 start it if requried.
13:09:52 sahid_ sean-k-mooney: if I understand, making it stop by default (the current spec), then in future have the internal clean that you are mentionning, and finally give users ability to choice active/stop, right?
13:11:40 sean-k-mooney no we dont want to give user a choice explictly. if they want the old behaivor they can use the old microverion but going forward we want evacuate to always mean evacuate to powerered off with the new micorversion
13:12:08 sean-k-mooney well its exiplcit in that its contorlled by the microversion but we dont want a new api parmater for it
13:12:39 sean-k-mooney so short term (A cycle) just allow evacuate to powered off
13:13:31 sean-k-mooney medeium term bug fix to not try and start the vm when the intended state is off as a non backporatble change to all drivers
13:14:04 sean-k-mooney that can be done in the A or later cycles
13:14:56 sean-k-mooney sahid_: does that sound ok to you.
13:26:21 sahid_ sean-k-mooney: yes understood, sounds good
13:26:38 sahid_ thank you for your help on it, I will update the spec to reflect that
13:27:02 sahid_ also open an issue

Earlier   Later