Earlier  
Posted Nick Remark
#openstack-nova - 2022-07-21
08:26:06 sean-k-mooney ok
08:26:17 bauzas this is just an idea
08:26:45 bauzas but we need to welcome them and make them sure they'll understand our language if they come
08:29:24 sean-k-mooney yep
08:29:46 sean-k-mooney which also might meen keeping slot free later in the week to be pland based on the hallway track and ops day
08:33:15 bauzas that's why I think we reasonably need a single day ops-friendly
08:33:28 bauzas or rather ops-welcome
08:33:44 bauzas the two other days wouldn't mean ops would be unfriendly
08:34:09 bauzas but we won't refrain ourselves to go into deepdive sessions if we feel we need to
08:38:38 sean-k-mooney ops are always welcome :)
08:39:06 sean-k-mooney well to me the ptg/design summit alwyas had 2 reasons to exist
08:39:27 sean-k-mooney direct feedback form ops/user/project about pain points
08:39:49 sean-k-mooney and brainstorming/deepdiving a problem with all that are interested in it
08:43:39 bauzas yup
09:10:40 bauzas gibi: could you please review https://review.opendev.org/c/openstack/nova/+/849133 even if we need to wait for unshelve
09:10:43 bauzas ?
09:10:52 gibi bauzas: ack
09:10:57 bauzas gibi: sean-k-mooney already provided me a +2
09:11:13 sean-k-mooney you keypair change
09:11:35 sean-k-mooney yes did you update it to disallow space or is that still allowed
09:11:45 sean-k-mooney im ok either way as long as we are intentional about it
09:11:46 gibi bauzas: you will come after auniyal's evac issue and the downstream cpupinning troubleshooting :)
09:11:53 bauzas sean-k-mooney: we were accepting the spacs before
09:12:02 sean-k-mooney bauzas: ack
09:12:11 bauzas spaces*
09:12:14 sean-k-mooney bauzas: cool ill try and review this again today or tomorrow
09:12:27 bauzas sean-k-mooney: there is a -W
09:12:32 bauzas because this is a 2.92
09:12:39 sean-k-mooney ah was just going to ask
09:12:45 bauzas nothing changed from the 2.91 revision
09:12:55 bauzas just I asked for 2.92
09:13:08 sean-k-mooney ok so this is quede behind which sepc
09:13:11 sean-k-mooney unshleve
09:13:14 sean-k-mooney or tenatn id
09:13:59 bauzas sean-k-mooney: https://etherpad.opendev.org/p/nova-zed-microversions-plan
09:14:06 bauzas should be unshelve
09:15:46 sean-k-mooney bauzas: do we want to add that to the chagne topic
09:16:41 bauzas which topic, sorry ?
09:17:13 sean-k-mooney the #openstack-nova topic
09:17:45 sean-k-mooney its currently "This channel is for Nova development. For support of Nova deployments, please use #openstack"
09:17:58 sean-k-mooney we used ot have the runway link there
09:18:09 sean-k-mooney we coudl add that if you think it woudl help
09:18:12 bauzas I didn't had time to provide an email yet
09:18:17 sean-k-mooney if not its fine
09:18:19 bauzas but I'll do it
09:25:28 MichielPiscaer[m] bauzas: I think that when ops travel to the PTG, they are probably newer then pre-train.
09:25:56 sean-k-mooney MichielPiscaer[m]: yes that has been my expiricne as well
09:26:12 sean-k-mooney the ones that only attend the summit/fourm are slower moving
09:26:50 sean-k-mooney the ones that know about and attend the PTG tend to run more recent versions and be more familar with how the comunity works and be more invovled in general
09:28:01 MichielPiscaer[m] indeed
10:16:22 EugenMayer after i upgraded to the latest xena serias with kolla, my nova docker container fails to authenticate to libvirt due to the new sasl password
10:16:32 EugenMayer 2022-07-21 09:19:23.586+0000: 6539: error : virNetSASLSessionServerStep:594 : authentication failed: Failed to start SASL negotiation: -20 (SASL(-13): user not found: unable to canonify user and get auxprops)
10:17:16 EugenMayer i ensure i merged the inventory/password file properly, but i seem to now be able to fix it via kolla. Is there a way i could fix that on nova's side manually=
10:20:55 EugenMayer my question would be, where would the sasl password be configured
10:29:10 sean-k-mooney EugenMayer: sorry had wifi issue
10:29:48 sean-k-mooney EugenMayer: in the libvirt section we have an optional connection uri option
10:29:50 sean-k-mooney https://docs.openstack.org/nova/latest/configuration/config.html#libvirt.connection_uri
10:30:21 sean-k-mooney EugenMayer: you may be able ot workaround your auth issues by adding parmaters to that
10:30:44 sean-k-mooney EugenMayer: https://libvirt.org/uri.html
10:30:48 sean-k-mooney is the libvift docs
10:30:55 EugenMayer what i did is i ran 'saslpasswd2 -c -p -a libvirt nova' with the sasl pw on the libvirt container
10:31:11 EugenMayer and verified that the auth.conf for nova has the same user/password
10:33:05 sean-k-mooney EugenMayer: auth.conf?
10:33:28 sean-k-mooney i assume that is a libvirt config file
10:34:22 EugenMayer that's a kolla config, but i guess it is mounted into nova, let me inspect the docker containerh
10:34:59 sean-k-mooney EugenMayer: i think the problem you are having is that you are tryign to use a libvirt feature that nova has no offical supprot for
10:35:05 sean-k-mooney EugenMayer: it might be possibel to make it work
10:35:21 sean-k-mooney but its not documenated as supported so its not a bug if it does not
10:35:26 sean-k-mooney its a new feature
10:35:45 EugenMayer "/etc/kolla/nova-compute/:/var/lib/kolla/config_files/:ro",
10:36:16 EugenMayer this probably means that those configs are used with a entrypoint and then generate the actual nova config, i dont know
10:36:51 sean-k-mooney EugenMayer: i assume you are tyring to use https://github.com/openstack/kolla-ansible/commit/d2d4b53d47df3b1a250c21404a8ec140873d4ce5 feature
10:37:18 EugenMayer sean-k-mooney i'am not really doing anything myself, i rather upgraded to the newest kolla version for xena, an they introduced this https://docs.openstack.org/releasenotes/kolla-ansible/xena.html#upgrade-notes
10:37:36 EugenMayer they are now, AFAIU talking with a sasl auth between nova and libvirt
10:37:48 EugenMayer and this is the default in this regard
10:38:04 sean-k-mooney i see
10:38:13 sean-k-mooney the nova comunity was nto invovled in that work
10:38:18 EugenMayer sean-k-mooney what you linked is perfectly right, but you also see, they default to enabling it
10:38:19 sean-k-mooney so its nice that it works
10:38:36 EugenMayer i see
10:39:13 sean-k-mooney https://docs.openstack.org/kolla-ansible/latest/reference/compute/libvirt-guide.html#sasl-authentication
10:40:04 sean-k-mooney so it looks like you need new passwoard in you passwords.yal
10:40:15 sean-k-mooney i assume you geneerated those and mreged them with your exsitng ones
10:41:10 EugenMayer did that already, the upgrade was not working without that
10:41:30 sean-k-mooney ya i would expect the templates to fail to generate the config
10:41:31 EugenMayer that is why i said on the compute, the auth.conf is created, has the right creds
10:41:37 sean-k-mooney ack
10:41:56 sean-k-mooney for now i would proably disabel the sasl auth and complete the upgrade
10:41:58 EugenMayer and i assured that the backend, libvirt, has set the sasls password for the particular user
10:42:06 sean-k-mooney then try and do a reconfigure later
10:42:13 EugenMayer yes, seems that this might be the option i should go for
10:43:16 sean-k-mooney i have not deployed kolla since wallaby by the way
10:43:27 sean-k-mooney so im not up to date on how they currenlty do things
10:44:28 sean-k-mooney lookign at the error
10:44:45 sean-k-mooney i wonder is this related to userids and group ids
10:44:55 sean-k-mooney libvirt is sayign the user does not exist
10:45:30 sean-k-mooney user
10:45:33 sean-k-mooney | not found: unable to canonify user and get auxprops
10:46:58 sean-k-mooney EugenMayer: kolla defiens the nova user id and group id https://github.com/openstack/kolla/blob/master/kolla/common/users.py#L148-L151=
10:47:08 sean-k-mooney but maybe that user is not create in the libvirt contaienr

Earlier   Later