Earlier  
Posted Nick Remark
#openstack-nova - 2017-09-25
16:00:38 dansmith can't have skip in the name
16:00:43 jaypipes jianghuaw: yep, will do.
16:00:46 bauzas jianghuaw: I'm already on it
16:01:15 claudiub what do I have to do?
16:01:34 jaypipes dansmith: I still like the package repository - integrated clustered kubernetes
16:01:35 mriedem claudiub: make the hyperv driver implement the get_inventory method
16:01:52 mriedem claudiub: to set the stage for vgpu support https://review.openstack.org/#/c/450122/
16:02:11 claudiub awesome
16:03:25 jianghuaw jaypipes, bauzas: thanks both:-)
16:04:37 claudiub welp, at the moment hyper-v reports some vgpu resources / stats, so i guess we'll have to move that around a bit.
16:10:08 jianghuaw bauzas, cool. thanks for +2 on the spec:-)
16:11:45 openstackgerrit Dan Smith proposed openstack/nova master: Use improved instance_list module in compute API https://review.openstack.org/505418
16:11:46 openstackgerrit Dan Smith proposed openstack/nova master: Remove legacy fault-loading routines https://review.openstack.org/505456
16:11:46 openstackgerrit Dan Smith proposed openstack/nova master: Fix CellDatabases fixture swallowing exceptions https://review.openstack.org/506312
16:11:47 openstackgerrit Dan Smith proposed openstack/nova master: Fix minor input items from previous patches https://review.openstack.org/506416
16:13:23 dansmith mriedem: I just pushed ^ so that that functional change isn't in the series
16:13:50 mriedem are you going to abandon that one?
16:13:59 dansmith sure
16:14:33 yufei could someone help review this, a small patch which remove re-auth logic from ironic client wrapper https://review.openstack.org/#/c/502382/
16:15:22 yufei keystone session supports to re-auth for 401 error, so re-auth in ironic client is unnecessary now.
16:15:35 openstackgerrit Merged openstack/nova master: Add recreate test for unshelve offloaded instance spawn fail https://review.openstack.org/506414
16:18:34 cdent mriedem: rgerganov is doing get_inventory for vmware, already running into some interesting wrinkles
16:19:48 openstackgerrit Eric Fried proposed openstack/nova master: Live Migration sequence diagram https://review.openstack.org/506370
16:20:55 mriedem yufei: you don't need to +1 your own change :)
16:21:05 mriedem yufei: how is that different from the [service_user] group of config options?
16:27:15 bauzas mmm, firefox loves me when I github blame the compute manager file
16:29:35 openstackgerrit Dan Smith proposed openstack/nova master: Add get_node_uuid() helper to ResourceTracker https://review.openstack.org/506730
16:29:36 openstackgerrit Dan Smith proposed openstack/nova master: Move allocation manipulation out of drop_move_claim() https://review.openstack.org/498947
16:29:36 openstackgerrit Dan Smith proposed openstack/nova master: Make allocation cleanup honor new by-migration rules https://review.openstack.org/498948
16:29:37 openstackgerrit Dan Smith proposed openstack/nova master: Pre-create migration object https://review.openstack.org/498950
16:29:37 openstackgerrit Dan Smith proposed openstack/nova master: Revert allocations by migration uuid https://review.openstack.org/498949
16:29:38 openstackgerrit Dan Smith proposed openstack/nova master: Refactor resource tracker to account for migration allocations https://review.openstack.org/506419
16:29:38 openstackgerrit Dan Smith proposed openstack/nova master: WIP: Make migration uuid hold allocations for migrating instances https://review.openstack.org/506420
16:29:39 openstackgerrit Matt Riedemann proposed openstack/nova stable/pike: Refactor ServerMovingTests for non-move tests https://review.openstack.org/507195
16:29:39 openstackgerrit Matt Riedemann proposed openstack/nova stable/pike: Add recreate test for unshelve offloaded instance spawn fail https://review.openstack.org/507196
16:29:40 openstackgerrit Matt Riedemann proposed openstack/nova stable/pike: Remove allocations when unshelve fails on host https://review.openstack.org/507197
16:31:39 yufei @mriedem, thanks for review, keystone session support to re-auth for 401 error no matter what is configred in [service_user], the code is at https://github.com/openstack/python-keystoneclient/blob/b29f478f28c4989156cfe87392cbd308e3f55c1e/keystoneclient/session.py#L432
16:31:59 yufei I’m not sure that whether I understand your question correctly
16:33:53 mriedem yufei: i'm trying to sort out when we can rely on ksa to re-auth and when we need to configure a service user token for re-auth
16:34:10 mriedem for example, if ksa is going to re-auth for us, then why do we even need service user tokens?
16:35:56 yufei the reauth logic was useful when we don’t use keystone session to build ironic client in the old version of nova, I forget the actual version of that, let me find
16:36:32 mriedem yufei: https://specs.openstack.org/openstack/nova-specs/specs/ocata/implemented/use-service-tokens.html if you're not familiar
16:38:01 openstackgerrit Merged openstack/nova master: Remove allocations when unshelve fails on host https://review.openstack.org/506458
16:38:21 openstackgerrit Merged openstack/nova master: Add _wait_for_action_fail_completion to InstanceHelperMixin https://review.openstack.org/506660
16:40:31 yufei I remember that, when user use a token to build keystone client, keystone is unable to reauth for 401 error, but nova service use username and password to build keystone session client to call neutron or neutron, keystone will help to reauth in this way
16:41:54 mriedem maybe edmondsw can reply in the patch, he knows more about ksa than i do
16:42:40 edleafe mriedem: do you have a sucke^H^H^H^H volunteer for API-SIG liaison for Nova?
16:43:06 mriedem edleafe: it's either you or cdent
16:43:18 yufei for live-migration or some other actions, user send a request to nova service with token is context, if token expired, action failed.
16:43:29 edleafe mriedem: it can't be
16:43:34 openstackgerrit Matthew Booth proposed openstack/nova master: libvirt: Don't VIR_MIGRATE_NON_SHARED_INC without migrate_disks https://review.openstack.org/507202
16:43:36 yufei thanks, mriedem
16:43:53 edleafe the liaisons are the ones who review changes *after* the cores have approved them
16:43:55 mriedem edleafe: then we just remove that entry, since gilliard isn't working on openstack
16:44:39 edleafe mriedem: ok, I can remove it now, and maybe you can find someone at the next Nova meeting
16:44:47 openstackgerrit Balazs Gibizer proposed openstack/nova master: Moving more utils to ServerResourceAllocationTestBase https://review.openstack.org/499539
16:44:48 openstackgerrit Balazs Gibizer proposed openstack/nova master: factor out compute service start in ServerMovingTest https://review.openstack.org/503037
16:44:48 openstackgerrit Balazs Gibizer proposed openstack/nova master: Test resource allocation during soft delete https://review.openstack.org/495159
16:45:26 yufei @edmondsw could you please help take a look at this patch when you are free? this is a patch about nova call ironic with keystone session, https://review.openstack.org/#/c/502382/
16:47:20 openstackgerrit Balazs Gibizer proposed openstack/nova master: Moving more utils to ServerResourceAllocationTestBase https://review.openstack.org/499539
16:47:21 openstackgerrit Balazs Gibizer proposed openstack/nova master: factor out compute service start in ServerMovingTest https://review.openstack.org/503037
16:47:21 openstackgerrit Balazs Gibizer proposed openstack/nova master: Test resource allocation during soft delete https://review.openstack.org/495159
16:49:01 openstackgerrit Masanori Itoh proposed openstack/nova master: Fix IoOpsFilter test case class name. https://review.openstack.org/507205
16:51:06 openstackgerrit Balazs Gibizer proposed openstack/nova master: use context mgr in instance.delete https://review.openstack.org/443764
16:51:06 openstackgerrit Balazs Gibizer proposed openstack/nova master: Transform missing delete notifications https://review.openstack.org/410297
16:51:07 openstackgerrit Balazs Gibizer proposed openstack/nova master: Send soft_delete from context manager https://review.openstack.org/476459
17:00:01 openstackgerrit Balazs Gibizer proposed openstack/nova master: Add functional for live migrate delete https://review.openstack.org/499583
17:01:58 gibi mriedem: Can I fast approve https://review.openstack.org/#/c/499583? It was already on the gate but got merge conflicts. So I resolved a trivial merge conflict and pushed it back
17:04:32 mriedem yeah
17:06:29 gibi mriedem: thanks. This was my first fast approve so I wanted to make sure :)
17:13:41 jianghuaw jaypipes, the default value 1 for display heads is requested by bauzas to cover the case where the head-counts don't return.
17:13:57 jaypipes jianghuaw: understood, but that's wrong. :)
17:14:38 jaypipes jianghuaw: if the virt driver cannot determine head counts, it simply should not write an inventory record for the VGPU_DISPLAY_HEAD resource class
17:14:44 jianghuaw it's possible if the vGPU doesn't support multiple-heads. By default at least it should support one head?
17:15:30 jianghuaw Then does it mean these vGPU can't be scheduled if it's requesting for one display head?
17:15:43 openstackgerrit Merged openstack/nova master: Copy some tests to a cellsv1 mixin https://review.openstack.org/505442
17:16:19 jaypipes jianghuaw: no, the opposite. by not having an inventory record for VGPU_DISPLAY_HEAD, that means all the pGPUs (or GPU groups) would be schedulable.
17:16:45 cdent jaypipes: in a choice between another process (just for placement-periodics) and cron, I’d definitely choose cron
17:16:59 jaypipes jianghuaw: if the hypervisor cannot determine display heads, then the flavor should not request VGPU_DISPLAY_HEAD resources
17:17:31 cdent mriedem, edleafe, dansmith: your thoughts on jay’s comments on https://review.openstack.org/#/c/504540/ encouraged
17:17:56 jaypipes jianghuaw: the problem of having an inventory of VGPU_DISPLAY_HEAD=1 would mean only a single instance requesting VGPU_DISPLAY_HEAD:1 would be possible on the host.
17:18:32 jianghuaw jaypipes, ah, I see.
17:18:47 jianghuaw yes, you're correct.
17:19:07 jianghuaw jaypipes, thanks for pointing it out:-)
17:20:40 mriedem gibi: oops something failed in the rebase here https://review.openstack.org/#/c/499539/9
17:21:06 gibi gibi: looking
17:21:08 gibi mriedem: looking
17:21:10 mriedem https://review.openstack.org/#/c/499539/9
17:21:11 mriedem oops
17:21:16 mriedem TypeError: _delete_and_check_allocations() takes exactly 2 arguments (4 given)
17:21:57 gibi OK I can fix that up quickly
17:24:08 openstackgerrit Balazs Gibizer proposed openstack/nova master: Moving more utils to ServerResourceAllocationTestBase https://review.openstack.org/499539
17:24:09 openstackgerrit Balazs Gibizer proposed openstack/nova master: factor out compute service start in ServerMovingTest https://review.openstack.org/503037
17:24:09 openstackgerrit Balazs Gibizer proposed openstack/nova master: Test resource allocation during soft delete https://review.openstack.org/495159
17:24:59 gibi mriedem: it should be better now
17:25:13 mriedem ok
17:31:21 openstackgerrit Jianghua Wang proposed openstack/nova-specs master: Support virtual GPU resources https://review.openstack.org/450122
17:32:06 jianghuaw jaypipes, see the revised spec ^
17:32:07 jianghuaw thanks.
17:35:33 jianghuaw bauzas, I did some minor change basing on jaypipes' comments. Need your help to review it again. thanks. https://review.openstack.org/#/c/450122

Earlier   Later