Earlier  
Posted Nick Remark
#openstack-nova - 2017-11-13
16:42:57 mriedem because i'm not sure why we'd be hitting this with a single scheduler CI job
16:43:07 efried rgr
16:44:06 mriedem johnthetubaguy: sdague: want to slam through this bit of spec accounting? https://review.openstack.org/#/c/516033/
16:44:44 mriedem stephenfin: you were +W on this before, just needed a rebase https://review.openstack.org/#/c/514782/
17:02:56 dtantsur folks, who's left the nova_cells meeting running? :)
17:03:40 efried mriedem dansmith Do you have the power to #endmeeting for dtantsur ?
17:04:23 dtantsur I suspect no
17:04:31 dtantsur somebody unrelated has started it, sorry for noise here
17:04:50 openstackgerrit Elod Illes proposed openstack/nova master: Transform instance-live_migration_pre notification https://review.openstack.org/482070
17:31:14 openstackgerrit Merged openstack/python-novaclient master: Updated from global requirements https://review.openstack.org/519165
17:38:58 openstackgerrit Elod Illes proposed openstack/nova master: Functional test: evacuate with no compute https://review.openstack.org/498482
17:42:56 mriedem sdague: i'm +2 on the keypair reset during rebuild change now https://review.openstack.org/#/c/379128/
17:45:38 openstack Launchpad bug 1731986 in OpenStack Compute (nova) "nova snapshot_volume_backed failure does not thaw filesystems" [Undecided,New]
17:45:38 tasker mriedem: https://bugs.launchpad.net/nova/+bug/1731986
17:46:11 tasker I'm in the proccess of writing and testing a patch to get my production clusters moving. I"ll hopefully have a review for the patch this afternoon.
17:46:35 mriedem tasker: cool, thanks
18:03:43 openstackgerrit Merged openstack/nova master: Updated from global requirements https://review.openstack.org/519127
18:06:31 sdague mriedem: +A
18:06:46 sdague took me a second to understand the or on the json schema, but I think I get it now
18:07:17 mriedem yeah the oneOf
18:07:28 mriedem we have that in the 'networks' entry in the server create schema too
18:19:44 mriedem hmm, why is it that we don't dump config options when n-api starts up?
18:20:04 mriedem i'm trying to fix the log formatting for placement-api in devstack, and the differences in the logs are a bit weird
18:20:41 mriedem oh i see why
18:21:04 mriedem https://github.com/openstack/nova/blob/master/nova/api/openstack/placement/wsgi.py#L60
18:24:26 openstackgerrit Surya Seetharaman proposed openstack/nova master: instance_mapping/request_spec records exist even after the instances are archived https://review.openstack.org/515034
18:38:14 openstackgerrit Merged openstack/nova master: Fix missing versioned notification sample https://review.openstack.org/516582
19:49:36 xarlos Hi all. I have just configured a number of nova node in separate region configs.
19:50:48 xarlos However, when I run "openstack hypervisor list" I get 2 listed from one region in this region, and none over in another region. I'm a bit confused.
19:51:01 xarlos I think I failed to add the region statement when I registered them using nova-manage.
19:51:13 xarlos How can I clear this out and get to re-add them? :-/
20:07:27 openstackgerrit Matt Riedemann proposed openstack/nova master: Log options at debug when starting API services under wsgi https://review.openstack.org/519462
20:12:24 openstackgerrit Eric M Gonzalez (tasker) proposed openstack/nova master: unquiesce instance on volume snapshot failure https://review.openstack.org/519464
20:12:53 mriedem tasker: we'll want a test for that
20:12:55 tasker hope I got that submitted all right.
20:12:56 mriedem when you get the time
20:13:06 tasker oh, of course you will. . )
20:13:10 tasker let me get some lunch.
20:24:40 mriedem tasker: comments inline when you get back
20:25:35 mriedem smcginnis: any idea how graceful cinder is about deleting a snapshot that is being created? concurrent requests i mean.
20:35:40 tasker mriedem: regarding your summary comment about splitting it up. after reviewing your comments I agree with you. how do you want me to proceed on that? resubmit with just the unqueisce and revisit the snapshot deletion later (after discussion about race) in another blueprint?
20:36:21 mriedem tasker: i don't think we need a blueprint, it's just another patch related to the same bug
20:36:35 mriedem tasker: but yeah split them up so quiesce is first and handled separately, we can backport that
20:36:45 mriedem then we'll see about the automatic cleanup of snapshots
20:37:20 tasker ok. I'll have that and a test (i hope) submitted in a little bit.
20:59:35 openstackgerrit Merged openstack/nova master: Enable reset keypair while rebuilding instance https://review.openstack.org/379128
21:26:17 tasker this url https://docs.openstack.org/nova/latest/reference/unit_tests.html is no longer valid. does anyone know where it ended up?
21:31:45 mriedem tasker: https://docs.openstack.org/nova/latest/contributor/testing.html#unit-tests ?
21:33:26 mriedem that page linking to the hacking repo docs seems like the wrong thing to do...
21:37:55 mriedem it was probably supposed to link to this https://github.com/openstack/nova/blob/master/HACKING.rst#creating-unit-tests
21:40:22 tasker sorry -- got sidetracked because of /.
21:41:06 tasker the latter is where I ended up after some trolling.
21:52:14 tasker thanks for the suggestion. I'm doing 2 now and just saw 1 in one of the other tests.
21:52:14 mriedem 1. use mock, not stubs or mox; 2. easiest to start with an existing test over the same function, copy it and tweak for what you need to test
21:52:14 mriedem i'll fix the link in our docs to point at nova/HACKING.rst, although that is pretty outdated
21:52:15 mriedem so nova saying it's using testr isn't really accurate anymore
21:52:15 mriedem mtreinish: nova uses os-testr which uses stestr now right?
21:52:15 mriedem there might be an existing test for the OverLimit failure, and your change makes it fail if yo'ure not mocking out the unquiesce_instance call you added
21:53:22 mtreinish mriedem: actually nova is using stestr directly in most places now
21:53:45 mriedem ah yeah stestr run '{posargs}'
21:59:17 mtreinish mriedem: if you're updating the nova docs, the user manual for stestr is: http://stestr.readthedocs.io/en/latest/MANUAL.html
21:59:45 mriedem yup, just linking to the main index
22:04:29 efried patchbot seems to be down
22:15:27 openstackgerrit Matt Riedemann proposed openstack/nova master: doc: fix link to creating unit tests in contributor guide https://review.openstack.org/519482
22:15:41 mriedem efried: looks like it's working for me
22:16:28 efried mriedem Okay. Maybe it just hates me. I just rebased this whole series https://review.openstack.org/#/c/516778/ and nothing popped up.
22:20:35 openstackgerrit Michael Still proposed openstack/nova master: Convert users of tune2fs to privsep. https://review.openstack.org/519484
22:20:35 openstackgerrit Michael Still proposed openstack/nova master: Move remaining uses of parted to privsep. https://review.openstack.org/519483
22:52:34 squid hi, i seem to sporadically have nova snapshots failing, with rbd as the backend, it throws the error "ERROR oslo_messaging.rpc.server ImageNotAuthorized: Not authorized for image fc378659-9d6f-41d6-8c7f-a7d08c2bdb54"
22:52:39 squid any idea what might be causing this?
22:54:38 calebb this is using the faster rbd backend snapshots as well
22:58:11 calebb sorry i'll put this in #openstack
22:59:24 tasker most places I see ImageNotAuthorized being thrown are a synonym to HTTPForbidden. check the OpenStack user that's initiating the call. Also check the glance / rbd authentication and make sure that glance has proper access to the requisite pools.
22:59:58 openstackgerrit Eric Fried proposed openstack/nova master: Test alloc_cands with non overlapping sharing RPs https://review.openstack.org/519380
23:00:37 openstack bug 1730730 in OpenStack Compute (nova) "AllocationCandidates.get_by_filters returns garbage with only sharing providers" [Undecided,New] https://launchpad.net/bugs/1730730
23:00:37 efried gibi Hey, I noticed that one of the other tests related to bug 1730730 started passing when incorporated into Jay's series, so I rebased yours on the same.
23:01:04 efried gibi The behavior changed - we're no longer getting the partial candidates (missing some resources). But we are still getting the duplicates. See above.
23:05:05 calebb tasker: thanks, i'll look into those things more, but at first glance (heh) they seem correct
23:06:14 openstackgerrit Eric M Gonzalez (tasker) proposed openstack/nova master: unquiesce instance on volume snapshot failure https://review.openstack.org/519464
23:08:17 tasker still not seeing the test in my head yet. I've got one test at nova/tests/functional/regressions/test_bug_1554631.py that deals with cinder OverLimit but doesn't deal with the snapshot_volume_backed function. and then there's nova/tests/unit/compute/test_compute_api.py that has several tests of snapshot_volume_backed.
23:10:22 tasker as best I can see it in my head, I want to mock the cinder_client. something like 1) cinder_client = mock({snapshot_volume.side_effect = cinderclient.exceptions.OverLimit}), 2) call snapshot_volume_backed with the mock cinder_client, 3) check that the proper exception was raised, and 4) check that the instance in unquiesecd / thawed.
23:11:06 mriedem tasker: yes, i'd avoid the functional test you referenced, and just add a unit test
23:11:14 tasker ok.
23:11:38 mriedem test_bug_1554631 is dealing with the volume/snapshot proxy apis which are deprecated and not what you're trying to fix
23:11:56 mriedem you'll also need to mock out the quiesce_instance call so that it "passes"
23:13:21 mriedem tasker: looks like you could hack something into test_snapshot_volume_backed_with_quiesce
23:13:40 tasker sorry .. first time using mock. so, this is a mock.patch(compute.api), altering quiesce_instance() and unquiesce_instance()?
23:13:43 mriedem make fake_volume_create_snapshot raise an exception
23:14:59 mriedem i'm not sure that you'd need to mock anything in there
23:16:17 tasker I thought about tweaking compute/test_compute_api.py to fit my needs but thought that might be too much. instead, I've fretted all afternoon. . /
23:16:29 tasker I'll see what I can do with that.
23:17:39 mriedem tasker: i'm thinking something like this http://paste.openstack.org/show/626204/
23:18:17 tasker yeah .. that's right where I was heading.
23:18:38 mriedem except self.compute_api.snapshot_volume_backed will raise that OverQuota failure, so you'd need to handle that as well
23:19:42 tasker overs="snapshots"? what's 'overs'?
23:19:51 mriedem part of the OverQuota error message
23:19:52 mriedem it's a kwarg
23:20:14 mriedem https://github.com/openstack/nova/blob/master/nova/exception.py#L1054
23:20:21 mriedem http://paste.openstack.org/show/626205/
23:23:31 tasker and then use "tox" to test it?

Earlier   Later