Earlier  
Posted Nick Remark
#openstack-nova - 2022-11-07
15:35:03 opendevreview Arnaud Morin proposed openstack/nova master: Add os_vif in nova-config-generator https://review.opendev.org/c/openstack/nova/+/863891
15:35:30 amorin bauzas and sean-k-mooney ^
15:35:36 amorin we talked about that two weeks ago
15:36:00 amorin I expect this change to also do the necessary change on docs.o.o (config reference_
15:36:03 amorin )
15:36:09 amorin am I correct?
15:43:36 opendevreview Dan Smith proposed openstack/nova master: Test ceph-multistore with a real image https://review.opendev.org/c/openstack/nova/+/860864
15:50:49 opendevreview Rajat Dhasmana proposed openstack/nova-specs master: Clarify client changes in rebuild spec https://review.opendev.org/c/openstack/nova-specs/+/856164
15:54:02 bauzas amorin: should work
15:55:05 amorin ack
16:53:07 opendevreview Amit Uniyal proposed openstack/nova stable/xena: Adds a repoducer for post live migration fail https://review.opendev.org/c/openstack/nova/+/863864
16:53:08 opendevreview Amit Uniyal proposed openstack/nova stable/xena: [compute] always set instance.host in post_livemigration https://review.opendev.org/c/openstack/nova/+/863792
16:57:02 opendevreview Amit Uniyal proposed openstack/nova stable/wallaby: Adds a repoducer for post live migration fail https://review.opendev.org/c/openstack/nova/+/863900
16:57:03 opendevreview Amit Uniyal proposed openstack/nova stable/wallaby: [compute] always set instance.host in post_livemigration https://review.opendev.org/c/openstack/nova/+/863901
17:01:16 opendevreview Amit Uniyal proposed openstack/nova stable/victoria: Adds a repoducer for post live migration fail https://review.opendev.org/c/openstack/nova/+/863902
17:01:17 opendevreview Amit Uniyal proposed openstack/nova stable/victoria: [compute] always set instance.host in post_livemigration https://review.opendev.org/c/openstack/nova/+/863903
17:38:51 opendevreview Dan Smith proposed openstack/nova master: Test ceph-multistore with a real image https://review.opendev.org/c/openstack/nova/+/860864
17:41:17 darkhorse Hi team - is there a standard way or recommended way of debugging under-development nova component under devstack environment?
17:42:38 darkhorse I tried to kill nova service from devstack and start my under-development nova in debug mode so that requests can be forwarded to the under-development nova.
17:44:04 opendevreview Stephen Finucane proposed openstack/nova master: hyperv: Mark driver as experimental https://review.opendev.org/c/openstack/nova/+/863910
17:44:05 opendevreview Stephen Finucane proposed openstack/nova master: vmwareapi: Mark driver as experimental https://review.opendev.org/c/openstack/nova/+/863911
17:44:42 stephenfin melwitt: dansmith: sean-k-mooney: I think that's what was suggested at the PTG. We don't deprecate, we just mark it experimental and remove if it starts costing us? ^
17:45:56 dansmith stephenfin: yes, although I thought we were using other words like "untested" (or at least I was)
17:46:11 dansmith experimental means "not yet ready for prime time, but soon" to me in most software features
17:46:36 dansmith so I'd rather use something that implies it has degraded to the current state, not that it's working towards a better one
17:47:03 dansmith (although it's not a huge deal of course)
17:51:04 melwitt stephenfin: pretty much. my understanding was/is no formal deprecation, no plan for removal, just a log message that warns the driver is untested. ppl will use the driver at their own risk. there was also mention of updating the driver matrix doc to mention something similar to the log message for the drivers in question
17:51:40 melwitt *suggestion of updating driver matrix
18:19:57 opendevreview Dan Smith proposed openstack/nova master: Test ceph-multistore with a real image https://review.opendev.org/c/openstack/nova/+/860864
18:32:12 opendevreview Dan Smith proposed openstack/nova master: Add virt/node module for stable uuids https://review.opendev.org/c/openstack/nova/+/863915
18:32:13 opendevreview Dan Smith proposed openstack/nova master: WIP Add get_available_node_uuids() to virt driver https://review.opendev.org/c/openstack/nova/+/863917
18:32:13 opendevreview Dan Smith proposed openstack/nova master: WIP: Pass service ref to init_host(), if exists https://review.opendev.org/c/openstack/nova/+/863916
18:32:14 opendevreview Dan Smith proposed openstack/nova master: WIP: Make resource tracker use UUIDs instead of names https://review.opendev.org/c/openstack/nova/+/863919
18:32:14 opendevreview Dan Smith proposed openstack/nova master: WIP: Persist existing node uuids locally https://review.opendev.org/c/openstack/nova/+/863918
18:32:15 opendevreview Dan Smith proposed openstack/nova master: WIP: Detect host renames and abort startup https://review.opendev.org/c/openstack/nova/+/863920
18:32:50 dansmith sean-k-mooney: all of this is marked WIP ^ because I haven't added more tests to cover any of the changes that aren't already covered (if any)
18:33:13 dansmith and because I need to look at it in gerrit to break up my tunnel vision
18:33:40 dansmith there are two functionals still failing because they test things this set intends to prevent, which are re-creating a compute node on a service and getting a different uuid
18:34:12 dansmith so I think the fix there is to make the services un-delete the compute nodes, but I left them failing to highlight and for discussion
19:19:12 opendevreview Dan Smith proposed openstack/nova master: DNM: Testing cinder devstack change https://review.opendev.org/c/openstack/nova/+/863925
19:57:36 opendevreview Dan Smith proposed openstack/nova master: Test ceph-multistore with a real image https://review.opendev.org/c/openstack/nova/+/860864
22:56:13 opendevreview Dan Smith proposed openstack/nova master: Test ceph-multistore with a real image https://review.opendev.org/c/openstack/nova/+/860864
#openstack-nova - 2022-11-08
00:56:10 opendevreview Dan Smith proposed openstack/nova master: Test ceph-multistore with a real image https://review.opendev.org/c/openstack/nova/+/860864
01:34:52 opendevreview Merged openstack/nova stable/yoga: Adds a repoducer for post live migration fail https://review.opendev.org/c/openstack/nova/+/861871
05:58:04 opendevreview Amit Uniyal proposed openstack/nova stable/ussuri: add regression test case for bug 1978983 https://review.opendev.org/c/openstack/nova/+/862603
05:58:05 opendevreview Amit Uniyal proposed openstack/nova stable/ussuri: For evacuation, ignore if task_state is not None https://review.opendev.org/c/openstack/nova/+/862604
08:59:44 ygk_12345 hi all
09:01:01 ygk_12345 I am trying to use pdb trace in the nova-api service in OSA setup. but when I start it manually , it is not dropping into the pdb shell. can anyone help me here ?
09:01:45 bauzas ygk_12345: you need to run a WSGI server that can support pdb
09:04:59 bauzas ygk_12345: example with httpd mod_wsgi https://modwsgi.readthedocs.io/en/master/user-guides/debugging-techniques.html#python-interactive-debugger
09:06:06 bauzas simple way with uwsgi https://stackoverflow.com/questions/18427948/how-to-debug-python-application-under-uwsgi
09:14:42 ygk_12345 bauzas: doesn't OSA nova-api support pdb ?
09:15:35 bauzas ygk_12345: I suppose nova-api wsgi app runs on a wsgi server (which I guess is httpd) which runs on daemon mode
09:16:03 bauzas if it would be uwsgi, that would still be a daemon
09:16:51 bauzas if you wanna use pdb, you need to run the wsgi server on demand and not as a daemon thru systemd or whatever
09:17:35 bauzas or rather use a remote pdb
09:18:16 bauzas but then you would need to make sure that you run on a single nova-api worker
09:19:36 ygk_12345 bauzas: I am using this manual command "/openstack/venvs/uwsgi-20.2.1-python3/bin/uwsgi --ini /etc/uwsgi/nova-api-os-compute.ini "
09:20:51 ygk_12345 bauzas: I have inserted importpdb;pdb.set_trace() in the file "/openstack/venvs/nova-20.2.1/lib/python3.6/site-packages/nova/objects/instance.py . but I see no pdb prompt
09:23:34 bauzas ygk_12345: you should probably add --honour-stdin and --workers 1 to the uwsgi command
09:23:47 ygk_12345 bauzas: let me try that
09:24:22 bauzas ygk_12345: and then, add a breakpoint in some easy rest endpoint call, like in nova.openstack.compute.api.servers on the get_instances() method
09:25:24 bauzas oh wait, you're not getting a BdBQuit error ?
09:25:58 bauzas that means that you haven't walked yet to where you added the breakpoint
09:26:20 ygk_12345 bauzas: still no luck
09:26:33 ygk_12345 bauzas: i am running the command nova list
09:26:46 bauzas ygk_12345: yup, because as i said just above, you haven't went to that line of code
09:26:53 bauzas s/went/gone
09:27:21 ygk_12345 get_all functions is executed from /openstack/venvs/nova-20.2.1/lib/python3.6/site-packages/nova/objects/instance.py right ?
09:27:27 bauzas ygk_12345: oh, you're not looking at the nova-api logs ?
09:27:44 ygk_12345 bauzas: no, I am tracing the code
09:28:09 bauzas ygk_12345: just to clarify, you won't get a prompt on your client call
09:28:23 ygk_12345 bauzas: yes
09:28:43 bauzas the interactive debugging session will run on the nova-api process that executes the server-side code for listing the instances
09:29:18 bauzas you can trigger it thru a client call of course
09:31:11 bauzas ygk_12345: to answer your question, no, a nova list doesn't lookup the instance records
09:31:38 bauzas ahah, I see your problem
09:32:01 bauzas since Newton, we don't expose the Instance record when you nova list
09:32:30 bauzas we rather expose an InstanceMapping record, eventually a BuildRequest object
09:32:39 bauzas you should rather try a nova show
09:36:26 ygk_12345 can anyone help me with this ?
11:31:31 opendevreview Rajesh Tailor proposed openstack/os-vif stable/zed: Move mtu update request into ovsdb transaction https://review.opendev.org/c/openstack/os-vif/+/863993
11:32:16 opendevreview Rajesh Tailor proposed openstack/os-vif stable/yoga: Move mtu update request into ovsdb transaction https://review.opendev.org/c/openstack/os-vif/+/863994
11:34:21 opendevreview Rajesh Tailor proposed openstack/os-vif stable/xena: Move mtu update request into ovsdb transaction https://review.opendev.org/c/openstack/os-vif/+/863995
12:15:05 admin1 hi all .. my nova-api logs is filled with ERROR oslo_service.periodic_task oslo_ db.exception.DBConnectionError: (pymysql.err.OperationalError) (2013, 'Lost connection to MySQL server during query' .. but it reconnects .. and this is happening every 1-2 mins .. other apis are fine
12:15:16 admin1 am I hitting some kind of nova limits or connection/cache timeouts
12:15:25 admin1 mysql connection limit is not reached
13:57:34 opendevreview Amit Uniyal proposed openstack/nova stable/ussuri: Adds a repoducer for post live migration fail https://review.opendev.org/c/openstack/nova/+/864006
13:57:35 opendevreview Amit Uniyal proposed openstack/nova stable/ussuri: [compute] always set instance.host in post_livemigration https://review.opendev.org/c/openstack/nova/+/864007
14:01:33 ygk_12345 bauzas: now I am able to get the pdb prompt in the uwsgi process, but whatever pdb commands I type are not executing. also the cursor is coming out of pdb prompt by one line and waiting there
14:36:24 opendevreview Dan Smith proposed openstack/nova master: Test ceph-multistore with a real image https://review.opendev.org/c/openstack/nova/+/860864
14:47:31 opendevreview Amit Uniyal proposed openstack/nova stable/ussuri: Adds a repoducer for post live migration fail https://review.opendev.org/c/openstack/nova/+/864006
14:47:32 opendevreview Amit Uniyal proposed openstack/nova stable/ussuri: [compute] always set instance.host in post_livemigration https://review.opendev.org/c/openstack/nova/+/864007
14:54:14 opendevreview Dan Smith proposed openstack/nova master: Test ceph-multistore with a real image https://review.opendev.org/c/openstack/nova/+/860864
15:01:44 Kirill_ Hi, do we have a meeting today?
15:03:26 elodilles Kirill_: if i'm not mistaken we will have @ 16:00 UTC
15:03:44 Kirill_ got it, thanks
15:16:20 opendevreview sean mooney proposed openstack/nova master: Support multiple config file with mod_wsgi https://review.opendev.org/c/openstack/nova/+/864014
15:26:13 bauzas reminder : nova meeting in 34 min
15:42:32 opendevreview Amit Uniyal proposed openstack/nova stable/train: Adds a repoducer for post live migration fail https://review.opendev.org/c/openstack/nova/+/863806

Earlier   Later