Earlier  
Posted Nick Remark
#openstack-nova - 2017-10-27
23:14:51 mriedem yeah
23:15:03 bauwser mriedem: looks like
23:15:12 mriedem probably need a .. note:: that says "don't pass device"
23:15:20 bauwser :)
23:15:28 bauwser I'll wait for the reply
23:16:00 bauwser mriedem: also FYI https://github.com/openstack/python-openstackclient/blob/master/openstackclient/compute/v2/server.py#L621
23:16:23 bauwser even if the user doesn't specify it, OSC forces it
23:16:28 mriedem yeah you already showed me that
23:16:45 mriedem i'd say that should all be deprecated in osc
23:16:48 bauwser ah yeah
23:17:24 mriedem looks like chenrui added a bunch of that
23:17:26 mriedem he's at huawei
23:17:37 bauwser cool
23:18:05 mriedem although it also looks like that predated his changes https://github.com/openstack/python-openstackclient/commit/95c8661f86e74c9d5217869a740da11350f1f0eb
23:20:17 mriedem https://github.com/openstack/python-openstackclient/commit/2c9d263611190996d64e35bc74a8575aeb25ed3e
23:20:20 mriedem anyway, deprecate it
23:20:26 mriedem Kevin_Zheng: ^ :)
23:20:28 bauwser mriedem: indeed
23:20:51 bauwser that change trampled your colleague
23:21:40 bauwser wait, it's Saturday now here
23:22:13 bauzas mriedem: before going to bed, I'd love your thoughts on https://bugs.launchpad.net/nova/+bug/1723165
23:22:14 openstack Launchpad bug 1723165 in OpenStack Compute (nova) "Volume is not detached when deleted VM was in error state" [Undecided,New]
23:22:52 bauzas that's not a quota problem, just the fact we don't unattach the volumz
23:23:28 bauzas I tend to think it's legit
23:23:39 Kevin_Zheng mriedem: will check latter, 4th Saturday of the month... still have to work
23:29:00 mriedem bauzas: sounds like a bug
23:29:08 mriedem we don't test image-defined bdms very well
23:29:15 mriedem error scenarios anyway
23:29:23 bauzas triaging it
23:29:40 bauzas if it's something else, then meh
23:31:21 mriedem bauzas: oh i see,
23:31:27 mriedem so it goes to error state in the compute service,
23:31:37 mriedem because that's going to create some new volumes in cinder from the snapshot bdms
23:31:42 mriedem cinder fails on the volume create because overquota
23:31:47 bauzas right
23:31:59 mriedem and we probably don't "detach" the volumes because we never attached them in the first place - because of overquota
23:32:41 mriedem or maybe we attached 2 but didn't finish one of them in time, idk
23:33:08 bauzas looks like it's the instance which fails, not the volume creation
23:33:11 mriedem would probably be helpful for them to give us the information about the volumes after the failure
23:33:17 mriedem like their status and if they show an instance id
23:33:20 bauzas because the volume is there
23:33:33 mriedem but the instance failure would be due to _prep_block_devices failing to create the last volume
23:33:41 mriedem because cinder returns overquota
23:33:45 mriedem they started with 3 volumes,
23:33:48 mriedem snapshot
23:33:53 mriedem set vol quota to 5
23:34:04 mriedem create new instance from the image snapshot which has 3 image-defined bdms in it,
23:34:09 mriedem so nova is going to create 3 more volumes from the snapshot bdms,
23:34:17 mriedem 2 will get created, 1 will fail with overquota from cinder
23:34:26 mriedem which makes _prep_block_devices fail and the instance goes to ERROR state on the compute
23:34:43 bauzas right
23:55:46 bauzas mriedem: last point, are we unquoting a shelved instance or not ?
23:56:09 bauzas of course, an offloaded instance
23:56:23 bauzas I think we shouldn't
23:57:11 mriedem can't talk about bugs anymore
23:57:22 mriedem go to be you crazy frenchman
23:57:26 mriedem *bed
23:58:16 bauzas :p
23:58:44 bauzas we have 18 open bugs and next week, I'll have a talk about bug triaging :p
23:59:45 mriedem yeah i know why you've been on top of it,
23:59:53 mriedem you should have to give a talk about bug triaging every quarter
#openstack-nova - 2017-10-28
00:00:10 mriedem we reserve quota for an unshelved instance,
00:00:14 mriedem *shelved offloaded
00:00:16 mriedem so that you can unshelve it
00:00:28 mriedem otherwise if we didn't, when you unshelve you might go overquota
00:00:38 mriedem i think i already triaged that bug once and marked it invalid
00:04:15 bauzas mriedem_afk: yup, and I just closed it again
00:04:26 bauzas anyway, /me disappears for now
01:52:26 openstackgerrit Matt Riedemann proposed openstack/nova master: Use ksa adapter for placement conf & requests https://review.openstack.org/492247
02:35:14 openstackgerrit Chen Hanxiao proposed openstack/nova master: libvirt: properly decode error message from qemu guest agent https://review.openstack.org/511459
03:01:12 openstackgerrit Merged openstack/nova stable/newton: libvirt: Don't disregard cache mode for instance boot disks https://review.openstack.org/515543
03:04:59 openstackgerrit Merged openstack/nova stable/pike: libvirt: Don't disregard cache mode for instance boot disks https://review.openstack.org/515538
03:34:54 openstackgerrit Yikun Jiang proposed openstack/python-novaclient master: Use utils.prepare_query_string instead of duplicated code https://review.openstack.org/515640
03:41:06 openstackgerrit OpenStack Proposal Bot proposed openstack/os-vif master: Updated from global requirements https://review.openstack.org/511035
03:54:01 openstackgerrit Yikun Jiang proposed openstack/python-novaclient master: Use utils.prepare_query_string instead of duplicated code https://review.openstack.org/515640
05:48:40 openstackgerrit Merged openstack/nova stable/ocata: libvirt: Don't disregard cache mode for instance boot disks https://review.openstack.org/515540
06:05:15 openstackgerrit OpenStack Proposal Bot proposed openstack/os-vif master: Updated from global requirements https://review.openstack.org/511035
06:38:06 openstackgerrit David Rabel proposed openstack/nova master: VMware: add support for graceful shutdown of instances https://review.openstack.org/494169
08:56:34 openstackgerrit Yikun Jiang proposed openstack/nova master: Add migration db and object pagination support. https://review.openstack.org/514904
09:16:52 openstackgerrit Yikun Jiang proposed openstack/nova master: Add migration db and object pagination support. https://review.openstack.org/514904
09:28:55 openstackgerrit Jianghua Wang proposed openstack/nova master: XenAPI: resolve VBD unplug failure with VM_MISSING_PV_DRIVERS error https://review.openstack.org/514902
09:56:37 openstackgerrit Yikun Jiang proposed openstack/nova master: Add migration db and object pagination support. https://review.openstack.org/514904
14:20:37 openstackgerrit David Rabel proposed openstack/nova master: Fix indent in configuring-migrations.rst https://review.openstack.org/516013
15:40:18 openstackgerrit Merged openstack/nova master: [placement] Limit number of attempts to delete allocations https://review.openstack.org/507224
17:51:21 openstackgerrit Matt Riedemann proposed openstack/nova master: Functional regression test for evacuate with a target https://review.openstack.org/490997
17:51:53 openstackgerrit Matt Riedemann proposed openstack/nova master: Pass requested_destination in filter_properties https://review.openstack.org/481116
17:52:55 openstackgerrit Matt Riedemann proposed openstack/nova stable/ocata: Functional regression test for evacuate with a target https://review.openstack.org/491000
17:54:00 openstackgerrit Matt Riedemann proposed openstack/nova stable/ocata: Functional regression test for evacuate with a target https://review.openstack.org/491000
17:54:44 openstackgerrit Matt Riedemann proposed openstack/nova stable/ocata: Functional regression test for evacuate with a target https://review.openstack.org/491000
17:56:31 efried alex_xu yt?
17:56:44 efried silly, middle of the night for you.
20:21:12 openstackgerrit Merged openstack/nova master: Use ksa adapter for placement conf & requests https://review.openstack.org/492247
23:21:50 openstackgerrit Chris Dent proposed openstack/nova master: [placement] Enable limiting GET /allocation_candidates https://review.openstack.org/513526
23:26:01 openstackgerrit Matt Riedemann proposed openstack/nova master: Functional regression test for evacuate with a target https://review.openstack.org/490997
23:26:13 openstackgerrit Matt Riedemann proposed openstack/nova master: Pass requested_destination in filter_properties https://review.openstack.org/481116
23:42:02 openstackgerrit Matt Riedemann proposed openstack/nova-specs master: Amend flavor description spec for GET /flavors API https://review.openstack.org/516033
#openstack-nova - 2017-10-29
08:39:31 gmann alex_xu: this is flavor schema patch - https://review.openstack.org/#/c/515413/
08:40:36 gmann alex_xu: i kept sort_key things as string only, i mean no restriction in schema. later i will make what all sort_key are useless in flavor case but we can do that in separate change
10:10:06 openstackgerrit Chris Dent proposed openstack/nova master: Optional separate database for placement API https://review.openstack.org/362766
10:48:05 openstackgerrit Maciej Kucia proposed openstack/nova master: SR-IOV passthrough: Check PF only if VF is enabled https://review.openstack.org/476642

Earlier   Later