Earlier  
Posted Nick Remark
#openstack-nova - 2017-10-04
23:00:14 dansmith and in these before, as long as you keep that test for the empty uuids I think you're good
23:01:17 openstackgerrit Ed Leafe proposed openstack/nova master: Add alternate hosts https://review.openstack.org/486215
23:01:18 openstackgerrit Ed Leafe proposed openstack/nova master: Return Selection objects from the scheduler driver https://review.openstack.org/495854
23:01:18 openstackgerrit Ed Leafe proposed openstack/nova master: Add Selection objects https://review.openstack.org/499239
23:01:22 edleafe dansmith: ^^ fixed per your comments
23:01:37 edleafe only the first patch changed; the rest are rebases
23:03:14 edleafe and with that it's time to make dinner
23:05:33 dansmith edleafe: cool, thanks
23:05:35 dansmith jaypipes: ^
23:08:59 openstackgerrit OpenStack Proposal Bot proposed openstack/os-vif stable/pike: Updated from global requirements https://review.openstack.org/493146
23:20:58 openstackgerrit OpenStack Proposal Bot proposed openstack/os-vif stable/newton: Updated from global requirements https://review.openstack.org/373293
23:37:19 openstackgerrit Merged openstack/nova stable/pike: Add nova-manage db command for ironic flavor migrations https://review.openstack.org/505903
23:40:32 openstackgerrit LIU Yulong proposed openstack/nova-specs master: Reset the instance keypair while rebuilding (spec) https://review.openstack.org/375221
23:51:12 openstackgerrit Merged openstack/nova stable/ocata: Fix --max-count handling for nova-manage cell_v2 map_instances https://review.openstack.org/507556
23:51:47 gmann mriedem: yes, that is kind of dead code. those are not going to be in filter_mapping as API 400 before it
23:54:23 gmann mriedem: we left this while doing schema for index. you have patch up for that cleanup otherwise i can push one.
#openstack-nova - 2017-10-05
00:58:18 openstackgerrit Merged openstack/nova master: Set group_members when converting to legacy request spec https://review.openstack.org/507938
01:45:25 openstackgerrit Takashi NATSUME proposed openstack/python-novaclient master: Microversion 2.54 - List/Show all server migration types https://review.openstack.org/430839
02:09:18 openstackgerrit Merged openstack/nova master: Fix CellDatabases fixture swallowing exceptions https://review.openstack.org/506312
05:40:42 ratailor Can anyone else reproduce this https://bugs.launchpad.net/nova/+bug/1720062
05:40:43 openstack Launchpad bug 1720062 in OpenStack Compute (nova) "Nova unit tests are failing " [Low,Incomplete]
05:55:22 openstackgerrit OpenStack Proposal Bot proposed openstack/os-vif stable/pike: Updated from global requirements https://review.openstack.org/493146
06:13:41 openstackgerrit Hironori Shiina proposed openstack/nova-specs master: Ironic: Resize and cold migration support https://review.openstack.org/449155
06:26:34 openstackgerrit OpenStack Proposal Bot proposed openstack/os-vif stable/pike: Updated from global requirements https://review.openstack.org/493146
06:40:48 openstackgerrit Lajos Katona proposed openstack/nova master: Change live_migrate tests to use fakedriver https://review.openstack.org/505202
07:53:03 openstackgerrit Radoslav Gerganov proposed openstack/nova master: VMware: serial console log (completed) https://review.openstack.org/450636
07:53:03 openstackgerrit Radoslav Gerganov proposed openstack/nova master: Move last_bytes into the path module https://review.openstack.org/509417
08:37:23 openstackgerrit Balazs Gibizer proposed openstack/nova master: Remove dead code of api.fault notification sending https://review.openstack.org/505164
08:42:02 openstackgerrit Rodolfo Alonso Hernandez proposed openstack/nova-specs master: Enable SR-IOV NIC offload feature discovery https://review.openstack.org/504895
09:32:15 openstackgerrit John Garbutt proposed openstack/nova-specs master: Support traits in the Ironic driver https://review.openstack.org/507052
09:35:23 openstackgerrit John Garbutt proposed openstack/nova-specs master: Support traits in the Ironic driver https://review.openstack.org/507052
09:37:41 openstackgerrit John Garbutt proposed openstack/nova-specs master: Support traits in the Ironic driver https://review.openstack.org/507052
09:39:33 openstackgerrit sahid proposed openstack/nova master: libvirt: rework _get_vpcu_total to return online pCPUs https://review.openstack.org/509730
09:40:24 bhagyashri_s johnthetubaguy: Hi
09:40:35 johnthetubaguy bhagyashri_s: hi
09:46:48 bhagyashri_s johnthetubaguy: I have one doubt regarding the patch https://review.openstack.org/#/c/409644/9, As from the microversion 2.45 refer: https://github.com/openstack/nova/blob/master/nova/api/openstack/compute/create_backup.py#L82 the image[id] is return in the response irrespective of rotation parameter value and we are skipping the creation of image if rotation parameter value is 0 then in that case the image[id] will give the KeyError.
09:48:08 johnthetubaguy bhagyashri_s: that does sound like an API change, which would need a new microversion and a new spec.
09:48:15 bhagyashri_s johnthetubaguy: so should i add the condition rotation should be greater than 0 at api microversion 2.45 or should bump the microversion separately
09:49:59 johnthetubaguy bhagyashri_s: maybe lets just go for returning null in the case of there being no image_id to return?
09:50:17 johnthetubaguy and forgot the microversion in this case
09:50:43 johnthetubaguy it looks like a bug in the new microversion really
09:51:41 johnthetubaguy lets see how that looks in code, I don't know the right way forward there
09:52:51 bhagyashri_s johnthetubaguy: ok.
09:53:11 bhagyashri_s johnthetubaguy: let me try
10:02:22 bhagyashri_s johnthetubaguy: i have checked by returning null but in that case at nova side that means through curl command it's retuning 202 accepted and using the command line it's returning "ERROR (CommandError): No Image matching None. (HTTP 404)" 404 not found and this inconsistency
10:03:25 openstackgerrit Merged openstack/nova master: doc: Add documentation for cpu_realtime, cpu_realtime_mask https://review.openstack.org/502056
10:12:27 bhagyashri_s johnthetubaguy: just need your opinion about my check as mentioned above
10:13:33 johnthetubaguy bhagyashri_s: did you return {'image_id': None} ?
10:14:12 johnthetubaguy oh, I see, the command line is looking up the image
10:14:20 johnthetubaguy I guess this will need a microversion
10:14:22 bhagyashri_s johnthetubaguy: return {'image_id': image.get('id', None)} like this
10:14:55 bhagyashri_s johnthetubaguy at https://github.com/openstack/nova/blame/master/nova/api/openstack/compute/create_backup.py#L83
10:15:26 openstackgerrit Balazs Gibizer proposed openstack/nova master: stabilize test_resize_server_error_and_reschedule_was_failed https://review.openstack.org/509750
10:15:49 johnthetubaguy bhagyashri_s: seems like we need a microversion, due to the new behaviour
10:16:00 bhagyashri_s johnthetubaguy: ok.
10:16:20 bhagyashri_s johnthetubaguy: and spec as well
10:16:29 johnthetubaguy bhagyashri_s: which means we need a nova-spec, sadly, because of that 2.45 change
10:17:23 openstackgerrit Balazs Gibizer proposed openstack/nova master: stabilize test_resize_server_error_and_reschedule_was_failed https://review.openstack.org/509750
10:17:43 bhagyashri_s johnthetubaguy: ok. I will work on it. Thank you for your opinion.
10:18:03 bhagyashri_s johnthetubaguy: :)
10:19:00 gibi stephenfin, bauzas: Would you like to support my embarrassment in https://review.openstack.org/#/c/509750/ ? :)
10:19:31 stephenfin gibi: :D Gladly
10:19:58 stephenfin gibi: thanks for yet another review on https://review.openstack.org/502056, btw
10:20:11 bauzas gibi: expenses reporting paperwork + fun with children
10:20:21 bauzas so maybe in the next 2 hours ?
10:20:27 bauzas :p
10:20:39 gibi bauzas: no hurries :)
10:22:03 gibi stephenfin: almost every added documentation is better than having no documentation at all.
10:45:13 openstackgerrit Radoslav Gerganov proposed openstack/nova master: VMware: serial console log (completed) https://review.openstack.org/450636
10:45:13 openstackgerrit Radoslav Gerganov proposed openstack/nova master: Move last_bytes into the path module https://review.openstack.org/509417
10:47:55 rgerganov does anyone know why Gerrit says "patch in merge conflict" even when the patch is cleanly rebased on master? https://review.openstack.org/#/c/509417/
11:15:24 openstackgerrit Rodolfo Alonso Hernandez proposed openstack/nova-specs master: Intel Fortville Dynamic Device Personalization (DDP) https://review.openstack.org/503001
11:28:49 openstackgerrit Rodolfo Alonso Hernandez proposed openstack/os-vif master: Move 'ips' field from Subnet object to VIF object https://review.openstack.org/508498
11:29:55 openstackgerrit Merged openstack/nova master: Add instance.interface_attach notification https://review.openstack.org/503089
11:30:33 openstackgerrit Merged openstack/nova master: Add instance.interface_detach notification https://review.openstack.org/506284
11:31:27 openstackgerrit Rodolfo Alonso Hernandez proposed openstack/os-vif master: Change Subnet.dhcp_server to contain multiple IPs https://review.openstack.org/509107
11:35:54 openstackgerrit Alvaro Lopez Garcia proposed openstack/nova master: Ensure that periodic reclaim cleans DB deleted instances https://review.openstack.org/323250
11:46:26 openstackgerrit Rodolfo Alonso Hernandez proposed openstack/os-vif master: Add support for Windows network commands https://review.openstack.org/487405
12:09:32 openstackgerrit Dinesh Bhor proposed openstack/nova master: TrivialFix: Fix the incorrect test case https://review.openstack.org/509758
12:10:35 openstackgerrit Balazs Gibizer proposed openstack/nova master: fix unstable shelve offload functional tests https://review.openstack.org/509759
12:25:46 tikitavi Hi, can anybody help? We have problem with running instances sometimes. The error is ERROR oslo_messaging.rpc.server IOError: [Errno 2] No such file or directory: '/usr/local/lib/python2.7/dist-packages/six-1.10.0.dist-info/METADATA'
12:26:07 tikitavi http://logs.openstack.org/91/500091/7/check/gate-functional-neutron-dsvm-ec2api-ubuntu-xenial/b05f013/logs/screen-n-cond.txt.gz?level=ERROR
12:26:51 tikitavi the problem is in stable/ocata and stable/pike
12:39:46 tikitavi sorry in stable/ocata only
12:41:49 tikitavi although sorry, in stable/pike too, the logs just moved to super-conductor
12:51:29 openstackgerrit Matt Riedemann proposed openstack/nova stable/pike: Set group_members when converting to legacy request spec https://review.openstack.org/509766
12:59:29 mriedem gmann: i'm working on a patch yeah
12:59:42 mriedem johnthetubaguy: i'm +2 on stvnoyes' new style volume attachment live migration patch https://review.openstack.org/#/c/463987/
13:00:09 johnthetubaguy mriedem: yeah I saw that, its on my TODO queue
13:00:26 johnthetubaguy production issues for a customer is slowing me down on reaching that quickly
13:01:55 andreykurilin hi folks! Did you merged recently related to listing servers?
13:04:34 andreykurilin It looks like there is an issue with detailed listing servers. This action takes > 1 hour in our gates :(
13:22:42 andreykurilin my fault, detailed flag is not used. so the regular listing servers stucks
13:25:24 tikitavi I really need help, for more than a month the review https://review.openstack.org/#/c/500091/ didn't pass because one or more instances cannot start because of the errors in n-cond
13:27:13 openstackgerrit Kevin Lefevre proposed openstack/nova stable/pike: Support qemu >= 2.10 https://review.openstack.org/509774
13:41:05 ArchiFleKs Hi, do you know if this (https://review.openstack.org/#/c/505673/) can be backported to pike on other releases that run on Xenial, I have the issue on Pike with OpenStack Ansible, were the compute node have been update to qemu 2.10
13:42:23 openstackgerrit Eric Berglund proposed openstack/nova master: WIP(5): PowerVM driver: ovs vif https://review.openstack.org/422512
13:43:52 openstackgerrit Gábor Antal proposed openstack/nova master: Transform instance.resize_prep notification https://review.openstack.org/465081
13:45:21 openstackgerrit Gábor Antal proposed openstack/nova master: Transform instance.resize_prep notification https://review.openstack.org/465081
13:47:42 openstackgerrit Takashi NATSUME proposed openstack/nova master: Enable cold migration with target host(1/2) https://review.openstack.org/408955

Earlier   Later