Earlier  
Posted Nick Remark
#openstack-nova - 2017-08-23
16:01:48 clarkb mriedem: ya just that one service has a weird log, once its fixed I can approve the change to index it
16:02:19 mriedem ok i'll investigate
16:08:49 openstackgerrit Stephen Finucane proposed openstack/nova master: nova-manage: Deprecate 'cell' commands https://review.openstack.org/496815
16:09:14 stephenfin mriedem, dansmith: ^
16:09:57 stephenfin I'd opt for bringing it into Pike, but only because it makes cliff migration in Queens simpler. Good to get rid of it either way
16:11:32 mriedem stephenfin: comments inline
16:11:34 mriedem dansmith: ^
16:16:47 openstackgerrit Stephen Finucane proposed openstack/nova master: nova-manage: Deprecate 'cell' commands https://review.openstack.org/496815
16:17:00 stephenfin mriedem: I think that should do it ^
16:19:04 sean-k-mooney stephenfin: regarding portbinding i dont think there is a neutron that is still supported that does not use portbining
16:19:35 stephenfin sean-k-mooney: Yeah, seems the decision is that we expect portbinding to be there be default now
16:20:09 sean-k-mooney stephenfin: i can ask on the neutorn channel but if you are using ml2 it is required. it may be posible to not use it if you use a monolitic plugin
16:20:31 sean-k-mooney monolitic plugins are effectivly deprected
16:21:06 sean-k-mooney to be part of the neutron stadium i belive you have to intergrate via ml2. that was a requirement for ovn anyway
16:30:23 openstackgerrit Merged openstack/os-vif master: Using assertIsNone() instead of assertEqual(None) https://review.openstack.org/496066
16:56:09 openstackgerrit Lajos Katona proposed openstack/nova master: Add functional migrate force_complete test https://review.openstack.org/496202
16:58:09 openstackgerrit Merged openstack/nova master: Assume neutron port_binding extensions enabled https://review.openstack.org/357726
17:01:30 openstackgerrit Lajos Katona proposed openstack/nova master: Add functional migrate force_complete test https://review.openstack.org/496202
17:47:30 mriedem stephenfin: +2 on the cell v1 nova-manage command deprecations, nice and generic wording there
17:48:02 mriedem would like dansmith's opinion on backporting for rc2, but i don't really think it's all that necessary, but we could if we want
17:56:40 dansmith mriedem: don't we need it in pike to call it actually deprecated? or are you just assuming your blanket cellsv1 deprecation covers it, even if not quite specific enough?
18:01:45 mriedem the latter
18:02:18 mriedem you could point the cli at an older deployment that's using cellsv1 still
18:02:29 mriedem not sure why anyone would, but i don't see a huge reason to backport
18:02:51 mriedem i also don't know if we'll remove cells v1 in queens or not
18:05:26 dansmith sure, okay
18:14:57 zen369 ERROR nova NotAllowed: Connection.open: (530) NOT_ALLOWED - access to vhost 'nova' refused for user 'nova'
18:15:01 zen369 any help?
18:46:39 knikolla hi all. We have a instance in error state after being live migrated to a server which doesn't have enough memory to start it. how can i migrate that to another host?
18:52:35 openstackgerrit Matt Riedemann proposed openstack/nova master: Add missing tests for _remove_deleted_instances_allocations https://review.openstack.org/496847
18:53:43 mriedem knikolla: cold migrate it?
18:53:58 mriedem you can cold migrate from stopped state
18:54:30 knikolla mriedem: i stopped it and ran `openstack server migrate <id>`
18:54:34 knikolla after that it goes back to error
18:54:37 knikolla saying it's not running
18:55:21 mriedem what says it's not running?
18:55:27 mriedem the api, compute service, other?
18:55:53 knikolla mriedem: http://paste.openstack.org/show/nfBmtEhE7SScwd0EimVQ/
18:59:02 mriedem that doesn't tell much - but assuming something failed on the compute service side
18:59:08 mriedem which is why it's recorded as an instance fault
19:00:49 knikolla checking compute logs
19:01:23 knikolla there's a InterfaceDetachFailed: Failed to detach network adapter device from c7703251-96d6-4a2e-b055-7c204ab104e7
19:12:20 openstackgerrit Chris Dent proposed openstack/nova-specs master: Add a spec for minimal cache headers in placement https://review.openstack.org/496853
19:15:36 cdent mriedem: do you recall when sdague comes back on the scene? I’d like to get his input on the microversion-parse adjustments I’ve got in progress
19:15:55 mriedem cdent: next week
19:16:02 cdent ✔
19:16:11 mriedem his wood paneled station wagon can tour the country only so long
19:16:45 mriedem https://encrypted-tbn0.gstatic.com/images?q=tbn:ANd9GcSIjcZl5KWDWlIYAkdWMwyv-yuZYuBUFN8RRc0MzWUwOfn_Uwfs
19:16:56 mriedem ^ is sdague last week
19:17:32 cdent ah the grand ol family truckster
19:17:35 cdent a fine fine auto
19:18:47 dansmith mriedem: he is in a station wagon, but I'm sure it doesn't have tree flesh on it
19:18:56 dansmith mriedem: and it might be powered by love and french fry oil
19:19:14 mriedem ha
19:19:28 mriedem subaru?
19:19:33 knikolla mriedem: the easy fix was to live-migrate another vm which was fine to make enough space for that to start, haha
19:19:35 dansmith yeah
19:19:50 mriedem knikolla: whatever works :)
19:46:36 mriedem now that i'm looking at the cold migration code, i see something odd
19:46:46 mriedem besides the fact it's called resize
19:47:15 exarr Hi all. I have applied the patch as noted here: https://review.openstack.org/#/c/428481/ to allow me to create volumes now, which is great, and seems to work.
19:47:19 mriedem i don't see how this would ever happen https://github.com/openstack/nova/blob/f1f55d48cc753ef3b6ab9b626148dec06e02f8cd/nova/compute/manager.py#L3773
19:47:26 mriedem added in https://review.openstack.org/#/c/73387/
19:47:33 exarr However, i'm stuck now with the following error: Exception during message handling: CantStartEngineError: No sql_connection parameter is establ
19:47:36 exarr ished
19:47:48 mriedem that exception is raised from driver.migrate_disk_and_power_off which is called from resize_instance, which is on the source host, after the dest host does and rpc cast from _prep_resize
19:51:46 mriedem there were like 10 people reviewing that change though so i'm not sure how they would all miss that
19:57:58 exarr mriedem: I assume you're not talking to me? :-)
19:58:03 mriedem correct
20:00:37 cdent mriedem: maybe something else (non-local) changed in the interim?
20:01:11 mriedem it has been 3 years, but looking at the code at the time that change was added, it's basically the same code
20:06:29 dansmith mriedem: did you figure out anything with the oslo timeutils thing yesterday?
20:06:52 dansmith I'm getting a weird native/naive comparison failure in unit tests when loading an object
20:06:55 dansmith for no apparent reason
20:09:01 mriedem dansmith: nope
20:09:03 mriedem wasn't looking
20:09:06 openstackgerrit Matt Riedemann proposed openstack/nova master: Add some inline code docs tracing the cold migrate flow https://review.openstack.org/496861
20:09:09 dansmith okay
20:09:26 mriedem and got totally distracted by https://review.openstack.org/#/c/73387/
20:13:21 mriedem dansmith: melwitt: are we having a sassy cells meeting this week? we should talk about cells v2 stuff for the ptg at some point, but that could be next week
20:13:45 dansmith mriedem: melwitt is still out today afaik, so whatever you want
20:14:01 dansmith I have a few things I'm planning on starting here pretty soon, but nothing pressing that anyone needs to know about
20:14:18 dansmith so if you want to punt again that's cool, and if you want it to be just us, then that's cool too
20:17:33 mriedem is there anything that's *not* cool?
20:17:37 mriedem fonzy
20:17:52 mriedem let's just punt until next week when mel is back
20:21:19 cdent dansmith: i saw that comparison problem yesterday while messing with timestamps and ovo. somewhere I had utcnow() and using utcnow(with_timezone=True) fixed it. May be totally unrelated but your comment collided with a memory
20:21:33 dansmith yeah totally unrelated
20:21:46 dansmith I was not doing anything with timestamps at all,
20:21:52 dansmith but I figured out why I was triggering the comparison
20:22:14 dansmith don't know why it was doing a naive/aware comparison in the first place, but once I stopped doing my stupid thing it went away
20:22:20 dansmith mriedem: ack on the meeting
20:22:24 cdent no, worries, it cost me little to type that
20:24:02 openstackgerrit Matt Riedemann proposed openstack/nova master: Add missing tests for _remove_deleted_instances_allocations https://review.openstack.org/496847
20:35:50 openstackgerrit Chris Dent proposed openstack/nova-specs master: Add a spec for minimal cache headers in placement https://review.openstack.org/496853
20:39:40 openstackgerrit Matt Riedemann proposed openstack/nova-specs master: Add a new section: "Upgrade impact" to the template https://review.openstack.org/456756
20:40:38 openstackgerrit Ed Leafe proposed openstack/nova master: WIP - add alternate hosts https://review.openstack.org/486215
20:40:39 openstackgerrit Ed Leafe proposed openstack/nova master: WIP - Add allocations to the values returned from the scheduler https://review.openstack.org/495854
20:40:39 openstackgerrit Ed Leafe proposed openstack/nova master: return alternates along with their allocations https://review.openstack.org/486253
20:41:26 cfriesen_ with placement/allocations where do we free up resources on deletion of an instance?

Earlier   Later